Simplify cloud operations and optimize costs with confidence.
Recently active
Is Prism supported on all/most current browsers? I have issues with Edge and to some extent IE11. Mostly on an AHV cluster that I am testing on before I migrate my producton to AHV. Typically it is with on the VM page and creating or otherwise managing VM's. Sometimes i have issues with the log in page rendering at all.
As a starting point of all or nearly all troubleshooting Nutanix recommends running Nutanix Cluster Checks (NCC). NCC identifies any risks or misses in the cluster configuration, hardware state, software components, networking and more. Checking for presence of orphan VM snapshots is part of NCC which, I think is quite convenient as chasing orphaned snapshots can be a hassle. Should you already know that there is a snapshot that is orphaned it can be removed with a single aCLI command. To be on the safe side always validate that the VM no longer exist. Otherwise, solution section of KB-3752 NCC Health Check: orphan_vm_snapshot_check lists all the steps necessary. More on the subject: NCC - why it is important to upgrade it
Hello I’m trying to figure out why We are unable to login in to Prism central as below message appear when trying to login: as it show in the dev tools ( Failed to load resource ) I have checked the apache and its not working but not sure if the issue has anything to do with httpdbelow is the status of httpd on the PCVMRedirecting to /bin/systemctl status httpd.service● httpd.service Loaded: masked (/dev/null; bad) Active: inactive (dead)nutanix@NTNX-1-A-PCVM:~$nutanix@NTNX-A-PCVM:~$ sudo service httpd startRedirecting to /bin/systemctl start httpd.serviceFailed to start httpd.service: Unit is masked. after that checked if a service does not start or there is any FATAL logs for i in `svmips`; do echo "CVM: $i"; ssh $i "ls -ltr /home/nutanix/data/logs/*.FATAL"; done /home/nutanix/data/logs/magneto.FATAL/pollux.ntnx-10-0-22-199-a-pcvm.nutanix.log.FATAL.20220510-022710.119479/home/nutanix/data/logs/lazan.FATAL/home/nutanix/data/logs/uhura.FATAL/home/nutanix/data/logs/catalog.FATAL/h
Gents, I have alerts in PRISM " Upgrade NGT version on VM to latest " to all VMs. Must I start one by one ? what's steps should I do ? Is there any effect in VMs ? *Note: VMs in production
I know in Calm you can create variables in the service, and then use those variables throughout the config using @@{service.variable}@@. However, it doesn't seem like you can use those in cloud-init scripts. I'd like to be able to pass a variable that the user sets at the time of deployment (the IP address), which would then be used in the cloud-init script. I've tried something like this, to no avail: code:#cloud-confighostname: HAProxy1fqdn: HAProxy1.domain.comssh_pwauth: yeswrite_files: - path: /etc/sysconfig/network-scripts/ifcfg-eth0 content: | DEVICE=eth0 BOOTPROTO="none" IPADDR="@@{HAProxy1.IP_Address}@@" PREFIX="24" GATEWAY="172.25.51.254" DOMAIN="VIPCUSTOMERS.COM VTINFO.COM" DEFROUTE="yes" ONBOOT="yes" DNS1="172.25.51.10" DNS2="172.25.51.2" IPV4_FAILURE_FATAL="yes" IPV6INIT="no"runcmd: - [ifdown, eth0] - [ifup, eth0] Where HAProxy1.IP_Address is a user defined variable. Any thoughts on how I might a
I thought I’d put together a set of sources to help with troubleshooting some of the popular issues with the Prism.If you ever lock yourself out of Prism account do not fret. Local admin account can be unlocked by logging into a CVM with nutanix user and resetting the password for the admin user.KB-8130 Prism Admin Account Locked With "Account locked due to too many failed attempts." If you ever need to find a Prsim Leader node as part of any troubleshooting:KB-1841 Checking which node is the Prism Leader. To verfify connectivity status between Prism Central and Prism Element use NCC check cluster_connectivity statusKB-3379 NCC Health Check: cluster_connectivity_status. For troubleshootimg PE to PC connectivity follow KB-6970 PE-PC Connection Failure alerts.Expand the list in the comments, help the community!
Hi, I was successful on setting up prism central on the community edition all working good. Further i extended the cluster capability by enabling Calm. I am able to access the calm UI and see all the functions available. As a next step i tried to deploy hycu blueprint from market place also tried to deploy one VM from my on disk image. Both get failed with below error. Please help. HTTPConnectionPool(host='172.16.xx.xx', port=4120): Max retries exceeded with url: /api/1/entities/get_by_name?name=Application-hycu--74b677a5-5cd9-4c49-9cb4-196e2d5e3be4 (Caused by ProtocolError('Connection aborted.', BadStatusLine("''",))) Regards, Aravind
I am looking to replace my SSL certificates on my Prism Central and Prism Element deployments with Lets Encrypt wildcard certificates. I can request the wildcard certificates easily enough sudo certbot -d example.com -d *.example.com --manual --preferred-challenges dns-01 --server https://acme-v02.api.letsencrypt.org/directory certonly I get generated three files: privkey = /etc/letsencrypt/live/example.com/privkey.pem chain = /etc/letsencrypt/live/example.com/chain.pem fullchain = /etc/letsencrypt/live/example.com/fullchain.pem Can anyone advise what openssl commands I can use to convert these .pem files to the required format needed for Prism Central/Prism Element? I have attempted multiple commands from https://www.sslsupportdesk.com/openssl-commands/ but I can't seem to find the exact one. I can also grab the intermediate/root certificates from here if I need additional certs. https://letsencrypt.org/certificates/ I'm looking to ultimately find a way to scrip
HiNutanix 6.6.2.5Installing Prism Central (1-Click Internet)When I deploy PC, then there is an option, as either:Small Large X-LargeWhen I selected small. Then I get 1.VM with “6 vCPUs, 26 GB of memory, and 500 GiB of storage.”I deploy it. And after there is an option to “Scale out PC”. I can scale out to 3-VM, so I get 3x “6 vCPUs, 26 GB of memory, and 500 GiB of storage.” But my question is, can I scale out from Small to Large as well ?And also from Small to X-Large..?Or I need drop my PC to achieve that..? I am new to nutanix. And I would like to know, which is the best approach for later on, when there is a need to expand.Also, as I have read, the Flow Virtual Networking requires “Advanced Networking”, which needs X-Large deployments.We might need that option later on. So I want to know, should I need to create X-Large deployment now, or can I change it later on. Thanks. RegardsRaul
Did you know you can restore a deleted VM from a leftover snapshot? If a virtual machine (VM) was accidentally deleted or migrated to a remote site provided the snapshot remains the VM can be recovered. When deleting a VM using Prism an option ‘Delete all snapshots’ is available. When the option is not selected the snapshots remain in the container and become orphaned. Similarly, when a VM is migrated to a remote site an is disassociated with the protection domain the snapshot remains. The recovery operation relies on a clone operation in aCLI. Clone a VM from a snapshot is essentially what happens when recovering the VM. Follow KB-6194 Cloning from AHV Orphaned Snapshots for a simple set of instructions on the process. Prism Web Guide contains more information on Disaster Recovery operations.
Hi All, I ran a Foundation upgrade pre-check on my single node cluster and now Prism times out when trying to log in as a standard user or admin and when I try to run acli in a ssh session to the cvm I get "Failed to connect to server: [Errno 111] Connection refused" Where to from here? Thanks in advance, Chris
Hello, this is Marc Malotke, your Nutanix SE. Today, I would like to provide you an overview of Prism Element, Prism Central, and Prism Pro. First, it is important to understand that our Nutanix solution is made up of two distinct pieces, Prism, and Acropolis. Since we will be diving into Prism today, I want to spend a moment talking about Acropolis. Acropolis is our operating system that includes the distributed storage fabric, the application mobility fabric, and let's not forget our Acropolis hypervisor that we like to call AHV. So what is Prism? Here's my definition. The single pane of glass to manage your data center that provides one-click infrastructure management, one-click operational insights, and one-click planning. This is very important because if you think about the way you go about your day in the data center, you are actually in and out of multiple tools and GUIs to not only manage your data center parts and pieces, but you also need even more tools and GUIs to try
Continuing on NGT series this post is about troubleshooting. Nutanix strongly believes power of the community and joint effort. You are not alone. We’re here to help. Nutanix engineers put together troubleshooting steps for some of the potentiall or more common scenarios out there for you: KB-3741 Nutanix Guest Tools Troubleshooting Guide: SSR login is successful but you receive "Error executing command: System identifier mismatch" after login. Guest Agent Service is not reachable. NGT is failing installation on a user VM/server where a Python environment already exists. NGT is failing in-place upgrade or uninstall on a user VM/server with "notify_cvm_of_uninstallation". NGT installation on Windows server 2008 R2 SP1 VM gives a warning "Hot-fix 2921916 is not installed on your system". NGT management from Prism Central fails with "NGT can only be upgraded on x/y VMs which have the latest version of NGT". NGT installation fails with "The system cannot open the file" error. NGT installat
What are the advantages to having UEFI set on a VM? UEFI firmware is a successor to legacy BIOS firmware that supports larger hard drives, faster boot time and provides more security features. Creation and starting VMs with UEFI firmware provide the following advantages. Boot faster Avoid legacy option ROM address constraints Include robust reliability and fault management Use UEFI drivers Are there disadvantages of enabling UEFI on a VM? Not per se however not all guest operating systems are compatible. For AHV Please always check compatibility matrix AHV Administration Guide: Compatibility Matrix for UEFI Supported VMs. Also keep in mind that cluster conversion and cross-cluster migrations might be affected by enabled UEFI: Ensure that you do not have VMs with UEFI boot firmware enabled when converting from ESXi to AHV. See Prism Web Console Guide v.5.16: In-Place Hypervisor Conversion. VMs with UEFI boot configuration do not boot after migration when migrating bet
Hi, I read the post https://next.nutanix.com/t5/Prism-Central/Download-Prism-Central/m-p/7863#M1. But after clicking on the download link for ESX, it turns out to download version 4.6 (I think this is an old version). How can I download Prism Central 5.1 or latest version? Or it is not free for download at all? Thanks, Liang
Did you know you can determine when a VM was created? All you need is a Prism Central instance.In PC UI go to Virtual Infrastructure –> VMs –> List –> in Focus dropdown choose +Add Custom and search for “Created Timestamp”.You can also find the time stamp from PC CLI using nuclei.For details refer to KB-9045 How to find a VM creation date and time in Prism Central. Always remember to configure adblocking plugin (if you are using one) in the Web browser to exclude Prism from checks. KB-8762 Prism home page shows "loading" when Web browser has AdBlock extension installed
Hi folks! Does anybody backup Prism Central VMs in a Protection Domain? I was just thinking about that, since I need to move all VMs from one AHV cluster to another. That's because I need to reinstall the cluster with ESXi for compatibility with some VMs. The only way I found out is to create Protection Domains and replicate the VMs to the new cluster. So does this work with PC VMs also? Regards, Andy
I need to move the PC VM to a different cluster and want to change the IP address of PC. I cannot find a description for version 5.16, only a very old one for version 4 that does not work. I also tried the instructions from https://portal.nutanix.com/page/documents/details/?targetId=Advanced-Setup-Guide-AOS-v5_16:ipc-cvm-ip-address-reconfigure-t.html but it does also not work. After reboot VM ip address is still the old one. Is there a description how to do it with PC 5.16?
This was answered 3 years ago and it was being “looked into” was anything created to be able to export Configuration from Prism Central? Where it was answered 3 years ago:https://next.nutanix.com/prism-infrastructure-management-26/export-import-backup-prism-central-element-configuration-17740 Thank you
Hello, We want to manage multi-tennancy using Nutanix. We have different clients and we want to give visibility them only to manage their VMs. When a client access to prism console, he only will be able to check his VMs and resources, create new machine on his side...not resources and VMs from the B client for example. Is this possible using the last version (5.10.2)? We have seen on last version Nutanix has launched Self Service Portal? Could it be helpful to achieve this requirement? Thanks in advance. Regards,
Is there any API to get VM UUID given VM name or any work around to get that? Is it possible to delete a VM given only VM name with API? Thanks in advance. Regards, Pawan
While some users might prefer the GUI (Prism Element) to keep tabs on an LCM upgrade, others might prefer the command line interface (CLI) method. Since LCM is a more GUI based product, it was not easy to track the status of an upgrade without skimming through the logs.However, starting in LCM 2.2, a command line utility was introduced to monitor the progress of an LCM upgrade. To use this, run the following command from any CVM that is currently up: lcm_upgrade_statusTo view sample outputs, check what various states mean, or different options that can be used with the above utility, take a look at KB 7914 in the Support Portal
I recently added a new 2-node cluster to my prism central. When I try to launch Prism Element from Prism Central. I get a pop massage “This action is only supported on cluster version 4.5.2 or later. Any thoughts? Prism Central: 5.11.2.1 AOS: 5.10.9.1 Foundation: 4.5.3
There might be a situation after a Prism Central upgrade you'll notice the following alert: Critical : IDF data from cluster {cluster_name} (uuid = 0005xxxxc-59xx-xx6x-0000-0000000x7xxx)is not up-to-date. There might also be a connectivity issue between Prism Central and Prism Element. You will also notice that your cluster is disconnected from Prism Central and the PE. The following Knowledgebase article can help you to validate and isolate the issue. Prism Element not reachable from Prism Central | IDF data not up to date after Prism Central upgrade
How to reduce size storage VM on PRISM? when I tried to reduce size storage vm i got error "Reducing the disk size is not allowed". Thanks
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.