Solved

SCOM Management Pack Monitoring data disappeared

  • 10 September 2019
  • 5 replies
  • 1040 views

Hello,

Lately I have been adding the Nutanix SCOM Management Pack version 2.4.0.0.
From the start on it worked fine as I handed over the Cluster information via Nutanix Cluster Discovery.
But now, a few weeks later, SCOM will not display any performance data of the clusters anymore.
I am not able to find out where exactely caused this problem. I have different Clusters AHV and ESXI as well as multiple OSVersions running.

Currently SCOM displays only one Cluster with it's information. From the other Clusters, there is no performance data shown.

All other clusters were discovered correctely (and the same way) but won't show their data anymore.

My situation looks like this - this dashboard is showing the clusters information. All other clusters (and their nodes) are not showing data - the dashboard stays empty.



What could have happend that the data is not reaching SCOM or SCOM not displaying it anymore?
Could it be too much Clusters on my system? I have 13 Clusters with (together) 43 Nodes installed. From the guidlines I read max is 15 Clusters.


Did someone face the same curious behaviour?

Best regards
Nicolas
icon

Best answer by Alona 24 October 2019, 07:00

@nicber 

To add to @HITESH0801response you could look into isolating the issue:

  • pack’s capacity: is it really too much for it to process? Try removing several clusters from it and see if there is any change in behavior
  • connectivity to components (potentially due to some changes in the environment) - is the hardware discovered correctly (IPMI connection is working), is it the SNMP traffic that is the problem?
  • try removing problematic clusters and discover them manually one by one. Not necessarily all of them but enough to observer behavior - when it fails? How it fails?
  • Are there any alerts that may point in the right direction?
View original

5 replies

Userlevel 4
Badge +4

Hello @nicber 

According to Nutanix Best Practise guidelines
https://portal.nutanix.com/#/page/docs/details?targetId=NSMP-Guide-v2-5:NSMP-Guide-v2-5


Nutanix recommends that one SCOM management server can efficiently manage up to 10 clusters or approximately 50 nodes.

 

The latest version of SCOM MP currently is 2.5.0.0, you can go through the release notes
https://portal.nutanix.com/#/page/docs/details?targetId=NSMP-Guide-v2-5:nsm-release-notes-nsmp-v2-5-r.html

 

Are you still facing the issue?

Go through the troubleshooting guide if it helps you to narrow down the issue 

https://portal.nutanix.com/#/page/docs/details?targetId=NSMP-Guide-v2-4:v24-nsmp-troubleshooting-r.html


Otherwise, I’ll recommend you to reach out to Nutanix Support once. 

Hope that helps!
 

Userlevel 4
Badge +4

@nicber 

To add to @HITESH0801response you could look into isolating the issue:

  • pack’s capacity: is it really too much for it to process? Try removing several clusters from it and see if there is any change in behavior
  • connectivity to components (potentially due to some changes in the environment) - is the hardware discovered correctly (IPMI connection is working), is it the SNMP traffic that is the problem?
  • try removing problematic clusters and discover them manually one by one. Not necessarily all of them but enough to observer behavior - when it fails? How it fails?
  • Are there any alerts that may point in the right direction?
We have the Exact same issue at one of our Customers Site.
REST-API seems to sometimes get data sometimes it won't.

If we find something i would share but i guess this is a topic for Nutanix Support...

Hello Alona , Hello HITESH0801 ,

 

I have now been in contact with the support for over a month. Finally we found the missing steps in installation:

The problem was that at adding Clusters to SCOM it asks for prism user credentials as well as IPMI Credentials.
After import of the cluster, the account information will be shared with the other Management Servers in the environment. But this was not the case. After changing the user and password on the cluster discovery in SCOM the “C:\Program Files\Nutanix Inc\SCOM\NutanixMPUtils\account” file was not synced with the other MS. So only a few clusters were showing their data in SCOM.

Solution is:

  1. Install Managementpack according to User Manual
  2. Import the clusters
  3. Additionally:
    IF SCOM does not discover the Management servers & gateway servers correctely, copy the registry key of Nutanix manually.
    Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Nutanix Inc
  4. replicate the account file to the other Management servers (and GW servers) and save it into the Nutanix installation Path.

Thanks to the support.
Nicber.

 

Userlevel 4
Badge +4

Thank you for sharing the outcome here!

Reply