Solved

Prism Central not accessible - how do I remove it and put another one in its place?


Userlevel 2
Badge +3
Hi All

I have a Prism Central VM and although it is pingable and shows as OK in the Prism Element, I get Server unreachable when I go to it. So I want to remove it and start again with the next version - I tried the NCLI command to remove the cluster and I get "Failed to process server response. Possible reason includes version mismatch between NCLI and Prism Gateway server." I am on version 5.5.7.1 of the AOS - how do I put the mismatch right so I can remove the PC VM? Or is there another way?

I also tried via NCLI ncli> multicluster get-cluster-state
[None]

So from a CVM view there is no cluster? very odd....

Thanks in advance.
icon

Best answer by Eric-The_Viking 27 November 2018, 22:44

Eric-The_Viking wrote:

Hi All

I have a Prism Central VM and although it is pingable and shows as OK in the Prism Element, I get Server unreachable when I go to it. So I want to remove it and start again with the next version - I tried the NCLI command to remove the cluster and I get "Failed to process server response. Possible reason includes version mismatch between NCLI and Prism Gateway server." I am on version 5.5.7.1 of the AOS - how do I put the mismatch right so I can remove the PC VM? Or is there another way?

I also tried via NCLI ncli> multicluster get-cluster-state
[None]


So from a CVM view there is no cluster? very odd....

Thanks in advance.



Well, I'll be a monkey's uncle as the saying goes - I removed the VM, did a clean up then added a new PC VM - same problem... hmmm... so I left it and I came across an article on NTP and test querying and noticed the cluster is on GMT and the PC VM was on PST (why did it not pick up the correct zone when I installed it?) Anyway, I changed the timezone and rebooted as per the instruction. Join it to the cluster from Prism Element failed again... hmmm, opened the PC VM console logged in to check the credentials, ah ha I got a prompt to change the password, that was progress! Changed the password, tried to join it again and hey presto the process to join went through all the startup questions and up it popped yay finally! No problems in NCC either.

View original

1 reply

Userlevel 2
Badge +3
Eric-The_Viking wrote:

Hi All

I have a Prism Central VM and although it is pingable and shows as OK in the Prism Element, I get Server unreachable when I go to it. So I want to remove it and start again with the next version - I tried the NCLI command to remove the cluster and I get "Failed to process server response. Possible reason includes version mismatch between NCLI and Prism Gateway server." I am on version 5.5.7.1 of the AOS - how do I put the mismatch right so I can remove the PC VM? Or is there another way?

I also tried via NCLI ncli> multicluster get-cluster-state
[None]


So from a CVM view there is no cluster? very odd....

Thanks in advance.



Well, I'll be a monkey's uncle as the saying goes - I removed the VM, did a clean up then added a new PC VM - same problem... hmmm... so I left it and I came across an article on NTP and test querying and noticed the cluster is on GMT and the PC VM was on PST (why did it not pick up the correct zone when I installed it?) Anyway, I changed the timezone and rebooted as per the instruction. Join it to the cluster from Prism Element failed again... hmmm, opened the PC VM console logged in to check the credentials, ah ha I got a prompt to change the password, that was progress! Changed the password, tried to join it again and hey presto the process to join went through all the startup questions and up it popped yay finally! No problems in NCC either.

Reply