Question

Nutanix CE 2-node cluster creation fails

  • 23 May 2019
  • 1 reply
  • 86 views

Hi all,

I try to setup a 2-node cluster wit the Nutanix CE edition. I have done the initial setup of my two servers. I can connect to both hypervisors and CVMs. But when I try to create the cluster, it fails with this error:


code:
admin@:172.22.0.24:~$ cluster -s 172.22.0.24,172.22.0.25 create


We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:


#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.


[sudo] password for admin:
ERROR:root:Failed to get CVM id
2019-05-23 10:25:07 INFO cluster:2484 Executing action create on SVMs 172.22.0.24,172.22.0.25
Atleast 3 nodes are required for cluster creation!. 2 IPs provided. Do you want to proceed? (Y/[n]): y
2019-05-23 10:25:21 INFO cluster:1040 Discovered node:
ip: 172.22.0.25
rackable_unit_serial: 00b88a1c
node_position: A
node_uuid: 1e306e2a-8026-4d0d-9f2c-8f2d541b0566


2019-05-23 10:25:21 INFO cluster:1040 Discovered node:
ip: 172.22.0.24
rackable_unit_serial: 34bddb06
node_position: A
node_uuid: 807771c4-587d-4c73-8d22-15cf2e98ddba


2019-05-23 10:25:21 INFO cluster:1058 Cluster is on arch x86_64
2019-05-23 10:25:25 INFO cluster:1184 iptables configured on SVM 172.22.0.24
2019-05-23 10:25:28 INFO cluster:1184 iptables configured on SVM 172.22.0.25
2019-05-23 10:25:28 INFO cluster:1192 Setting the cluster functions on SVM node 172.22.0.24
2019-05-23 10:25:28 INFO cluster:1197 Configuring Zeus mapping ({u'172.22.0.25': 2, u'172.22.0.24': 1}) on SVM node 172.22.0.24
2019-05-23 10:25:29 INFO cluster:1192 Setting the cluster functions on SVM node 172.22.0.25
2019-05-23 10:25:29 INFO cluster:1197 Configuring Zeus mapping ({u'172.22.0.25': 2, u'172.22.0.24': 1}) on SVM node 172.22.0.25
2019-05-23 10:25:29 INFO cluster:1213 Creating cluster with SVMs: 172.22.0.24,172.22.0.25
2019-05-23 10:25:29 INFO cluster:1224 Will seed prism with password hash $6$.gSsW/C8eA./0t$Z4PaEQxBuHpriA7Pnc2fh6exfcE3yKbDLVAKyZnBmZhfbhDklQ5Z2qXCEkOuVzdoCruPei3uvGA3axNh3xBfL1
2019-05-23 10:25:29 CRITICAL cluster:1249 Cluster initialization on 172.22.0.24 failed with ret: RPCError: Client transport error: httplib send exception: url:/jsonrpc payload:eyIub2lkIjogIkNsdXN0ZXJNYW5hZ2VyIiwgIi5rd2FyZ3MiOiB7ImRuc19zZXJ2ZXJzIjogbnVsbCwgIm50cF9zZXJ2ZXJzIjogbnVsbCwgImN2bV9iYWNrcGxhbmVfaXBfbWFwIjoge30sICJyZWR1bmRhbmN5X2ZhY3RvciI6IDIsICJub2RlX2xpc3QiOiBbWyI4MDc3NzFjNC01ODdkLTRjNzMtOGQyMi0xNWNmMmU5OGRkYmEiLCAiMTcyLjIyLjAuMjQiXSwgWyIxZTMwNmUyYS04MDI2LTRkMGQtOWYyYy04ZjJkNTQxYjA1NjYiLCAiMTcyLjIyLjAuMjUiXV0sICJwcmlzbV9wYXNzd29yZCI6ICIkNiQuZ1NzVy9DOGVBLi8wdCRaNFBhRVF4QnVIcHJpQTdQbmMyZmg2ZXhmY0UzeUtiRExWQUt5Wm5CbVpoZmJoRGtsUTVaMnFYQ0VrT3VWemRvQ3J1UGVpM3V2R0EzYXhOaDN4QmZMMSIsICJjbHVzdGVyX25hbWUiOiAiIiwgImNsdXN0ZXJfZXh0ZXJuYWxfaXAiOiAiIiwgImNsdXN0ZXJfZnVuY3Rpb25fbGlzdCI6IFsibmRmcyJdLCAiY29udGFpbmVyX25hbWUiOiBudWxsfSwgIi5tZXRob2QiOiAiY2x1c3Rlcl9pbml0In0=
Traceback (most recent call last):
File "/home/afg/src/main/builds/build-ce-2018.05.01-stable-release/python-tree/bdist.linux-x86_64/egg/util/net/http_rpc.py", line 139, in send
File "/home/afg/src/main/builds/build-ce-2018.05.01-stable-release/python-tree/bdist.linux-x86_64/egg/util/net/http_rpc.py", line 60, in request
File "/usr/lib64/python2.7/httplib.py", line 1017, in request
self._send_request(method, url, body, headers)
File "/usr/lib64/python2.7/httplib.py", line 1051, in _send_request
self.endheaders(body)
File "/usr/lib64/python2.7/httplib.py", line 1013, in endheaders
self._send_output(message_body)
File "/usr/lib64/python2.7/httplib.py", line 864, in _send_output
self.send(msg)
File "/usr/lib64/python2.7/httplib.py", line 826, in send
self.connect()
File "/home/afg/src/main/builds/build-ce-2018.05.01-stable-release/python-tree/bdist.linux-x86_64/egg/util/net/http_rpc.py", line 32, in connect
File "/usr/lib64/python2.7/httplib.py", line 807, in connect
self.timeout, self.source_address)
File "/usr/lib64/python2.7/socket.py", line 571, in create_connection
raise err
error: [Errno 111] Connection refused





Does anyone know waht to do?

Thanks,
Stefan

1 reply

I had a very similar error when I tried 2 nodes. Added a third and it works fine - I guess CE still doesn't support 2 nodes!

Reply