Connectivity issue -- fresh install


Badge +7
Hello,I have a Dell R730 that we tried installing community edition on fresh. We previously had 3x R730 single node cluster installs, but realized we cannot cluster together the 3 single node clusters together, despite meeting the 3 node requirement.Anyhow, so we were trying to reinstall Community Edition with one server first having it as a multi node cluster. Install went fine, used same network settings as before, went into the resolv.conf later and added DNS servers, but we cannot connect to Prism gateway. From the Host I SSH into the CVM, typed ncli, and I get this error:Connection refused (Connection refused)Cannot connect to the Prism Gateway. Everything worked fine before as a single node cluster, no idea why it is failing now.........

4 replies

Userlevel 2
Badge +12
Hi Matt,
ncli will only work after a cluster is formed. Are the other two nodes working as single node cluster?

Thanks,
Userlevel 4
Badge +17
Matt_Palmer
could you post the cluster status ?
could you ping all CVM IP each other ?

Badge +7
Sorry for the late replies; When installing it as a multi node cluster on one machine, I have to create the cluster myself? It is not automatically created?
Userlevel 2
Badge +12
Matt_Palmer No it won't create a cluster like the single node cluster. Please find the procedure to create a mulitnode cluster from the following blog, You can refer to the "Creating the Cluster" section for instructions to create a multinode cluster.

http://next.nutanix.com/t5/Nutanix-Connect-Blog/Part-I-How-to-setup-a-three-node-NUC-Nutanix-CE-cluster/ba-p/15257

Please note we require all the nodes that are forming a cluster to be in an unconfigured state when you execute the command referred in the blog. So if your other two nodes are single node clusters by themselves then you cannot create a cluster. The other two nodes need to be in unconfigured state.

Reply