Cluster Init Page on Mac OS X


Badge +6
Anyone get the cluster_init page to work to setup a new block from their mac. I have done 4 or 5 installs and I never can get the page to come up. What am I doing wrong? How do I detect the IPv6 nodes online?

13 replies

Userlevel 2
Badge +10
And i thought it was me, not having a mac 😉

Which browser are you using? Safari? FF? Chrome? all of `em?

Have you tried to connect to the IPv6 address directly, not the name?

I think the main problem is that most of us just aren't experienced enough with IPv6, and as soon as the plug&play doesn't work, we are doomed 😉
I will post some troubleshooting steps from my history later on.
Userlevel 2
Badge +10
- First, make sure, you are following the guidelines in the "Setup Guide".(enable IPv6 if disabled on your host, IPv6 link-local enabled)- Make sure, the node interfaces you are about to use have a link, and are in the same vlan than your host- the name resolution works "automatically" thanks to the "bonjour" protocol. MacOS: enabled per default -> check Windows: install iTunes/bonjour Linux: install avahi (distribution-specific)if NTNX--NODEID-CVM.local.:2100 is not working:1. try to ping it:ping6 NTNX--NODEID-CVM.local.-> ping6 works => problem is@browser (see below)-> ping6 doesn't work => problem elsewhere => goto 2.2. "test" your own ipv6: Linux/MacOSX: # look up your IP ifconfig | grep inet6 -> if nothing is returned, you do not have ipv6 enabled on the specific interface # ping it ping6 # multicast ping (one packet) ping6 -c1 -I ff02::1 -> now at least your host should have replied # again, more than one packet stop it with ping6 -I ff02::1 -> at least now, you should have received answers from more hosts than yours, depending on IPv6 hosts on your network answering multicast requests (most do, nutanix too) Windows: - use ping instead of ping6 - no need for -I switch now either try to fix/debug the name resolution (A), or (B) access one of the Nutanix CVMs via its IP address directly(A) debug name resolution - local/personal firewall configured for bonjour/avahi? - try it without firewall Linux: # browse all of the type "nutanix" avahi-browse _nutanix._tcp -> empty? try: # browse all IPv6 bonjour records avahi-browse -alr | grep IPv6 -> if you can see devices/hosts here, but no nutanix, chances are that either some Firewall in between is blocking bonjour, or the nodes/their avahi service have a "problem" # for completeness / (i that line after power on / reimageing of nodes) # of course, this works only if things are "OK" for i in a b c d;do avahi-resolve -6 -n NTNX--${i}-CVM.local.; done MacOSX: dns-sd -B _nutanix._tcp # i guess there is an app for that (graphical) too 😉 Windows: http://support.apple.com/kb/ht2703(B) ping a nutanix node directly -> we will need to get the IPv6 Address manual - connect to the Hypervisor and from there to the CVM (vmware: viclient / KVM: virt-manager) - inside the CVM: ip -6 addr show eth0 | grep inet6 # afaik its always eth0 (ymmv) try to ping it now (see above) -> if unsuccessful -> ask your network/fw/switch admin 😉 -> if ping works, access the IPv6 IP in the browser, but beware, you need to put the IPv6 address into square brackets, like: http://[fe80::5054:ff:fe96:2fb2]:2100/cluster_init.html3. KVM check -> service avahi-daemon status # if not running, (re)-start it # check it by resolving its own hostname: -> avahi-resolve-host-name `hostname`.local. # this should work for sure -> avahi-browse _nutanix._tcp # you should see every node 2 times (IPv4 & IPv6)Browser -> disable proxy if set -> Firefox: about:config -> network.dns.disableIPv6 should be false -> Chrome: no specific settings? -> Safari: no specific settings? -> IE: no specific settings?Of course all of that might be too time-consuming compared to just use the IPv4-Address (if known), but do it once, and you might discover what you are doing wrong all the time 😉
Badge +6
I'm going to try this. Can I test this on the block I have that is already initialized? Is there a test page?
Badge +8
Cluster init page will be redirected, if the cluster is already initialized. Please open a support case on your next install, if you can't get cluster_init page working as expected.
Userlevel 2
Badge +10
as jerome said, cluster_init.html should redirect to cluster_status.html (once the node you are connecting to is part of a cluster)
Badge +2
Just make sure igmp snooping is off on you vlan/switch.
Userlevel 1
Badge +17
Just to follow up here, make sure that on a Mac, you have an IPv6 link local address set up:

System preferences -> Network -> Select your interface -> Advanced -> TCP/IP Tab:
http://next.nutanix.com/t5/image/serverpage/image-id/100iB540A8E5B93E0D54/image-size/original?v=mpbl-1&px=-1

Like mluksch (how the heck do I tag a name in a reply?) said, make sure you are in the same subnet/VLAN, and that your switch isn't dropping IPv6 link-local traffic.

Next thing I usually do is just disabling IPv4 on my interface and only keep the IPv6 link-local address active. The reason for that is relatively simple. Most browsers on Mac prefer IPv4 over IPv6 (just google for that). This way, I can make sure that it isn't a browser problem caused by trying to resolve the link-local address on the DNS using IPv4.

I usually use Safari as the browser for the cluster_init page, since this is tightly coupled in to OSX, and seems to have the best Bonjour integration. Chrome doesn't do this that well, there used to be a seperate plugin for Chrome called DNSSD (dnssd.me), but that is no longer being published, although you can still find versions online.

That does the trick for me in 99% of the cases. Don't forget to switch IPv4 back on after you are finished with the cluster_init part. I can also try to put a video doing this on my personal blog if anyone is interested?
Userlevel 2
Badge +15
Auto discovery with Nutanix

Windows

- Apple Bonjor service must be installed and running
- DNSSD browser plugin is optional (makes for easy troubleshooting, if nodes do not discover via DNS-SD browser you will not be able to use autodiscover)
- IPv4 and IPv6 must be enabled
  • You can turn on IPv6 only for the discovery via DNS-SD but if you try to do name resolution of the .local. Bonjor will not properly resolve the .local. and cause an error. You must have IPv4 enabled to allow for .local. resolution
- IPv4 must have an autoconfigure IP address….169.254.x.x
  • If you are assigned a DHCP IPv4 address it will fail as you are not on the same subnet as the Nutanix Nodes[list]
  • One caveat to this is on a cluster that was destroyed via Cluster destroy will retain the IPv4 addresses. If that is the case you will need to be in the same IPv4 broadcast domain.
  • If DHCP is enabled on the IPv4 address and it does not have a autoconfigure IP simply change to static and configure a 169.254.100.100 address with a 255.255.0.0 subnet mask[/list]- Use Chrome or Firefox with the DNS-SD plugin to browse CVM Host name (remember to grab the trailing . after .local.)
    - Paste the CVM host name address with port :2100 appended to the hostname. Recommended browser is IE


    Troubleshooting with Windows

    - ipconfig /all is your friend
    • Make sure your IPv4 address is a 169.254.x.x address
    • Make note of the adapter number which is listed after Local Link address in the case below it is %11
    -
    - Ping -6 ntnx-13am2k020104-a-cvm.local.%11

    Apple

    - Install DNS-SD browser on either Google Chrome or Firefox
    - For the Ethernet port Enable IPv6 only

    - Use Chrome or Firefox with the DNS-SD plugin to browse CVM Host name (remember to grab the trailing . after .local.)
    - Paste the CVM host name address with port :2100 appended to the hostname. Recommended browser is Safari



    Creating a Helper VM for VLAN’ed networks

    To alleviate the issues of VLAN tagging and all of the confusion and problems with expanding the cluster VLAN’s pose, asking the customer to create a “Nutanix Helper” VM has been very helpful. This also eliminates the need to physically be in front of the Nutanix nodes to do the configuration.

    Using the setting defined in the Windows portion of the guide ask customer to create a VM 2008R2 or Windows 7 and install the required plugins. Bonjor, Firefox or Chrome and DNS-SD plugin.

    During the network preinstallation ask the network team which VLAN they were going to assign the ESXi host and the Nutanix Controller VM. Typically these are in the same VLAN and the ports are set to Trunk. For this example the network team wishes the ESXi host and Nutanix CVM to be in VLAN 100.
    During this discussion ask the network team if they would be able to set VLAN 100 as the default VLAN for the specific trunked ports that they are going to use for the Nutanix. Explaining that by setting the default VLAN the ESXi host management and Nutanix Controller will be in the proper VLAN. This also allows for seamless expansion. If they continue to place the new Nutanix nodes with the proper default VLAN expansion is as easy as a single click. Without setting the default VLAN you must manually assign the VLAN tags and adds complexity to expansion.

    Once the network ports are configured and Nutanix Servers are powered on you should be able to place the “Nutanix Helper VM” that is running on an ESXi hosts somewhere in the users environment to work off of a port group that has the VLAN ID 100 tagged on it.

    Now that you have the “Nutanix Helper VM” and the ESXi hosts and CVM all in the same VLAN 100 broadcast domain you can start the setup using the Chrome or Firefox browser to see the DNS-SD host names.

    Note that you will have to connect to the “Nutanix Helper VM” through the VMware vCenter console as it typically will not be accessible because of the requirement of have an IPv4 autoconfiguration IP address.

    Utilizing this configuration allows you to move the “Nutanix Helper VM” into different port groups to setup different clusters all around the world and is not dependent on a physical connection to the same switch.
  • Userlevel 2
    Badge +13
    I use helper VMs. So much easier to send a new block out to a site and just tell them to plug it in, then I can configure the block from whereever I am.
    Userlevel 2
    Badge +15
    I agree Josh, I am doing a deployment of 320 nodes this week and all have been done from a helper VM. The datacenter is miles away. Much more comfortable as well.

    Setting Native /default VLAN is the most important part if doing with the helper VM.

    Tony
    (Nutanix SE Midwest)
    Badge +3
    Hi all, the Bonjour browser for Mac helped me get the link to the nodes so I could login with any browser during setup. https://www.macupdate.com/app/mac/13388/bonjour-browser
    Badge +6
    Bonjour Browser.... Nice!
    Badge +6
    A couple of troubleshooting tips you may way to try if you see issues with cluster_init.html

    If you can reach cluster_init.html but aren't able to see any nodes discovered:
    + Try a couple of different browsers such as chrome, safari, firefox if possible

    + Check if the cvm is advertising with (you can ssh to the cvm via ipv6 or ipv4 if you have configured IPs)
    nutanix@cvm_All NOS versions_$ ncli cluster discover-nodes
    nutanix@cvm_NOS 3.5.3+_____$ discover_nodes

    + If you cannot see the cvm see itself with discover_nodes then the cvm is not advertising and there may a different issue. This is sometimes seen with nodes that have been possibly removed from a cluster previously.

    + if discover-nodes/discover_nodes works but cluster_init.html does not then you may want to connect your computer / helper VM to the local subnet to rule out any firewall issues.

    Hope that helps!

    Reply