Solved

Cluster create fails


Badge +3
hi,
i am trying to create a cluster manually.

3 cvms, all pinging each other, ssh to each other OK, network access OK

nutanix@NTNX-xxx-B-CVM:xxx:~$ cluster -s a,b,c create2015-01-29 02:34:48 INFO cluster:1663 Executing action create on SVMs a,b,c2015-01-29 02:34:48 WARNING genesis_utils.py:325 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abort)2015-01-29 02:34:49 WARNING genesis_utils.py:325 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abort)2015-01-29 02:34:50 WARNING genesis_utils.py:325 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abort)2015-01-29 02:34:51 WARNING genesis_utils.py:325 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abort)2015-01-29 02:34:52 WARNING genesis_utils.py:325 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abort
esxi 5.5 u2
nos 4.0.2.2

I ve done a lot of install of 4.0.2.2, first time I see this error.

vinny
icon

Best answer by cbadami 2 February 2015, 06:54

Hi Vinny,

Please run the below commands:

# cluster start all

If the above command does not work, try the below on all nodes in the cluster individually:

# genesis start
OR
# genesis restart


Then try running the below command from one of the nodes:

# cluster start all

Please let me know if that helps.

View original
This topic has been closed for comments

4 replies

Userlevel 3
Badge +14
Hi Vinny,

Please run the below commands:

# cluster start all

If the above command does not work, try the below on all nodes in the cluster individually:

# genesis start
OR
# genesis restart


Then try running the below command from one of the nodes:

# cluster start all

Please let me know if that helps.
Badge +5
Genesis should be started on the nodes in order to create the cluster. You'll want to determine what is in the genesis.out file to see why genesis is not starting. From that CVM, cd to ~/data/logs and enter 'tail -f genesis.out'. Once you have the messages in that log, post to here and we can take a look. That log will constantly overwrite itself as genesis crashes and tries to restart; the tail -f will allow messages to scroll on the console.
Badge +3
thanks men,
a restart of genesis solved the issue,
vinny
nutanix@NTNX-d0d628b0-A-CVM:172.20.1.221:~/data/logs$ tail -f genesis.out
2018-06-20 08:01:01 INFO ipv4config.py:809 Netmask is 255.255.255.0
2018-06-20 08:01:01 INFO ipv4config.py:843 Discovered network information: hwaddr 50:6b:8d:b4:f2:09, address 172.20.1.221, netmask 255.255.255.0, gateway 172.20.1.254, vlan None
2018-06-20 08:01:01 INFO node_manager.py:4693 Svm has configured ip 172.20.1.221 and device eth0 has ip 172.20.1.221
2018-06-20 08:01:01 INFO node_manager.py:6326 No cached Zeus configuration found.
2018-06-20 08:01:01 INFO ipv4config.py:809 Netmask is 255.255.255.0
2018-06-20 08:01:01 INFO ipv4config.py:843 Discovered network information: hwaddr 50:6b:8d:b4:f2:09, address 172.20.1.221, netmask 255.255.255.0, gateway 172.20.1.254, vlan None
2018-06-20 08:01:01 WARNING node_manager.py:6275 /home/nutanix/data/zookeeper_monitor/zk_server_config_file could not be opened
2018-06-20 08:01:32 ERROR ipv4config.py:1595 Unable to get the KVM device configuration, ret 1, stdout , stderr br0-backplane: error fetching interface information: Device not found

2018-06-20 08:01:32 INFO node_manager.py:4798 Could not discover the hypervisor backplane IP configuration

I got this error while checking genesis details. someone could help ?