Have questions about how the Nutanix Platform works? Looking to get started - start here!
Recently active
There may come a time when you must expand your cluster storage capacity since you predict more data will be added to the cluster in the near future.Also, you are already short of space and cannot gain any more space by deleting the old snapshots and removing VM not needed any more, etc.In that situation, assuming you have empty slots in your hardware chassis and depending on the type of the drive you are adding you will need to follow the instruction in your nutanix portal document titled “Adding a Drive”.If you do not have any more disk slot on your hardware to, you may have to add a new node to your cluster altogether, so it can expand the capacity of your cluster. This has the benefit of adding memory and cpu resources as well.
You might have noticed vCenter alarms regarding CVM memory usage being high, and when you look at Prism console for the CVM, you will see it reports 100% but no prism alert will has posed up.This is a known visual artifact with passthrough VMs that could be bypassed by creating a customize alarm in vCetner for VM memory usage and apply it to all other VMs or to the folders containing the VMs. Disabling the builtin vCenter alarms in conjunction with enabling this customized alarm can by pass the alarm reported for VCM while continue reporting any VM high memory usage. For better understanding of this issue and its by pass please review the KB 4465 in your nutanix portal.
What is the color of your Cluster Health Heart? We use the following stoplight style color code to report the quick view of the cluster health, in the form of a color coded heart. Cluster Healthy Cluster has at least one Warning Alert Cluster has at least one Critical Alert To view the specific alert(s), on the Health Dashboard click on any of the selections from the Home Dashboard, or click on the Heart directly to be taken to the Health Dashboard overview. Selection Options:Remote Sites Hosts Services Protection Domains …Once you have selected a specific Alert to review, you will have several options for the Alert.Run Check Turn Check Off Alert Policy ScheduleMake a note of the Alert name, and locate the Alert ID by searching for the Alert name in the Cluster Settings, Alert Policies view. False Positive Alerts Occasionally there will be an alert that will inaccurately show a warning or failure. When this occurs there are a few options to correct
Just curious if there is going to be an update to the Move API documentation to explain how we can create a migration plan from ESX to AHV. Currently the only example shown is for AWS to AHV and when we try to substitute that payload with values from ESX it fails. Create plan example is here:http://{{ move-ip-address }}:8082/#/v2api/plans/createplan We’ve tried using this same template to create a plan for ESX, but it seems to choke on the network identification section with a return code of {'ApiVersion': '2.0.0', 'Code': 20512, 'Message': "Invalid Network Mapping for VM 'NX-TEST'. Ensure sufficient user permissions on source environment to fetch network information.", 'State': 'Error'}(we have validate permissions) This appears to be the part of the payload that it doesn’t like:From the AWS example: "Networks": [ { "SourceID": "vpc-8e1c3de7", "TargetUUID": "343eaa8f-a251-4ec0-8ede-729c97f7cddc" } We’ve substituted these AWS specific
If you already have a functioning “Syslog Server” and you would like to forward cluster logs to it, you can follow instructions in:“https://portal.nutanix.com/#/page/docs/details?targetId=Advanced-Admin-AOS-v511:set-rsyslog-config-c.html”However, presently (as of fall of 2019) the activity entities like Alerts/Events/Audits in prism central cannot be redirected to remote syslog servers. This can be changed in future releases of PC and AOS will be reflected in Release notes.
Let’s say you have Nutanix cluster with 24 CPU cores and 2 sockets and now you’re confused regarding the terminology. vCPU and cores per CPU and how to provision CPU to a Virtual Machine confusing you? Let’s break the terminology down in simple terms!In the world of Hardware, we have sockets and cores. In a host, there would be 2 sockets(or CPU) and 12 cores in each socket, resulting in 24 cores.So what is a vCPU?vCPU corresponds to the number of sockets for the VM. Cores per vCPU correspond to cores in a socket, so in conclusion, if you have provisioned your VM with the following configuration:2 vCPU 4 core per vCPUIn this scenario, your VM would have 2 sockets and 8 cores in total.How can I provision my vCPU, is there a guide or documentation regarding it?Absolutely yes, please give the following article a readCPU Configuration So is there a way to overprovision my CPU?Absolutely yes, please give the following article a readCPU Oversubscription
There are times, when we need to move a vm disk to a different container on the same AHV Cluster.For e.g. : We may want to move this VM Disk on a container with De-Dupliction Disabled. To relocate a virtual machine’s disk to a different container on the same AHV cluster, following steps are required:Requirements for the Move:Source Container ID (where the vmdisk is located originally) Destination Container ID (our target container on the same cluster) VM Disk(s) UUID (UUID of each disk we need to move “acli vm.get <vm-name>”) Power-off the VMSummary of Steps:Determine the vmdisk_uuid of each virtual disk on the VM. Make sure the VM for which the VMdisk we are migrating is powered off. Use the Acropolis Image Service to clone the source Virtual Disk(s) into Image(s) on the target container. Attach the disk from the Acropolis Image(s) which created in Step 3 to the VM. Remove the VM disk that is hosted on the original container Optional: Remove the cloned VMdisk from image services
When expecting to witness changes in storage utilisation performance, increase in free space in particular, please be aware that the change may not take effect immediately.There are two main types of Curator scans:Scheduled Scans Curator Full Scan — in 6 hrs after the last Full Scan Curator Partial Scan — in 1 hour after the last Partial Scan. Triggered Scans — as a response to a situation in the cluster where Curator is urgently required.For more information:KB-2101, KB-2924.Posts here in NEXT community curator task type list or a search.Nutanix University video on Curator.Nutanix Bible on monitoring Curator tasks Application Mobility Fabric (AMF)
Suppose you have Erasure Coding (EC-X) enabled on all of your containers. Over time you find that workload structure and type has changed and is no longer suitable for EC-X. What do you do?Since migrating VMs between containers is a disruptive task alternative approach would be to disable EC-X on a container.In preparation for the task there are a couple of factors we recommend are taken into consideration:There will be increased I/O at the storage layer. Once EC-X is disabled on a container additional data will be written to the container and replicated. The influx of the data can be estimated by reversing EC-X gains. Expect temporary increase of storage utilisation in addition to calculations above. Parity data will not be removed immediately. Parity data size can be reverse calculated based on the same EC-X gains estimates. There are no guardrails in terms of storage utilisation once EC-X is disabled. Please make sure there is sufficient space for the decoded data to be written —
Below are new knowledge base articles published on the week of October 13-19, 2019.KB 8018 - NCC Health Check: ns_proto_consistency_check KB 8094 - NCC Health Check: disk_status_check KB 8148 - NCC Health Check: cpu_avx_check KB 8315 - Files: chmod/chown on TLD fails on first mount with CentOS 6 KB 8356 - [Nutanix Objects] Objects 1.0.1 is missing from LCM Inventory KB 8358 - [Nutanix Objects] Unable to download access keys in browsers like Mozilla Firefox KB 8360 - LCM pre-check test_esx_ha_enabled failed but HA is actually enabled on vCenter KB 8362 - Alert - A130209 - IO failures to a data source in an external repository KB 8364 - Windows prompts for restart after migrating vms on a VDI cluster to a node with a different CPU generation KB 8366 - AHV | Guest VM running CentOS 7 may hang when CPU is hot added KB 8367 - AHV | VM may be restarted unexpectedly due to memory corruption KB 8371 - Nutanix Move - Upgrading using the offline bundle may show an unexpected error KB 8379 - AHV
Let's say that you have 25 Gbps SFP+ Network card in your host and have created a Windows Virtual Machine with a 1 Gbps Nic card and now confused regarding the bandwidth for the virtual machine and how the Virtual Nic of the VM is different than the Host Nic when it comes to bandwidth and functionality. vNic is the software NIC emulation in the VM and is just a driver and in latest VMs the NIC is para-virtualised, which means that the NIC and Operating System is aware of the Host Physical NIC capability and understands that the vNic is just a driver. So what basically is this driver supposed to do? The vNic driver is really an API between the guest and the hypervisor so the vNic bandwidth is totally disconnected from any physical hardware. So what is the Physical NIC card then? Physical Nic is the physical network adapter connected to your physical switch and is responsible for the transfer of packets in your environment. So how Para virtualised vNic is better, does it have any advanta
What can be encrypted? What configuration is supported? At which layer the data is encrypted? Which layer encryption is more secure?Nutanix offers three options of data encryption:Data-at-Rest Encryption - Self Encrypted Drives (SEDs) - cluster's native or external KMS for software-only encryption. If the Controller VM cannot get the correct keys from the key management server (KMS), it cannot access data on the drives. If a drive is re-seated, it becomes locked. If a drive is stolen, the data is inaccessible without the KEK (key-encrypting-key) (which cannot be obtained from the drive). If a node is stolen, the key management server can revoke the node certificates to ensure they cannot be used to access data on any of the drives. Data-at-Rest Encryption - Software Only For AHV, the data can be encrypted on a cluster level. This is applicable to an empty cluster or a cluster with existing data. For ESXi and Hyper-V, the data can be encrypted on a cluster or container level. The c
Nutanix provides customer support services in several ways:The Pulse feature sends diagnostic data from customer clusters to Nutanix Support on a regular schedule. This enables Nutanix to deliver proactive, context-aware support to customers, monitor customer clusters and provide assistance when, or even before, a problem occurs. This data collection is anonymized, securely transmitted, has no effect on system performance and only basic system-level data needed to monitor the health and status of the cluster are collected. The Pulse framework also allows Nutanix Support Engineers to remotely collect logs from customer clusters on demand with customer approval but without needing assistance from the customer. This saves time in the data gathering stage of the troubleshooting process. Instead of asking the customer to run commands and send the output, which could go back and forth several times, the Support Engineers can just collect the logs themselves via the connection provided by Pul
If you have a 3 node cluster and your data resiliency is okay, you can handle a failure of 1 node, this is termed as FT-1 (Fault Tolerance), or alternatively RF-2. RF-2 is Redundancy Factor - 2, which states that all data in your NX environment has another copy distributed in your cluster, which makes it possible for the cluster to sustain a single component failure and is the default fault tolerance configuration for your cluster. What if you're handling a larger cluster and your workload is extremely critical? Redundancy factor 3 is a configurable option that allows a Nutanix cluster to withstand the simultaneous failure of two components by saving 2 copies of all your data in two different nodes in your NX environment. The requirements for RF-3 are as follows- Minimum number of Nodes in your environment should be 5 and the storage containers should be RF-3. Want to know more about how RF-3 works? Redundancy Factor 3 So what if you created a storage container with RF-2 and
We have below script which is changing VM's project from default to some other project but after we execute invoke-webrequest, we notice that it will change Vm's "spec_version" to different number than it's in out $body variable. That's the reason why invoke-webrequest is given below error. Just before we run invoke-webrequest, we checked that vm's configuration metadata "spec_version" is same than in $body that we are trying invoke. So it seems that invoke-webrequest is somehow first changing the vm's spec_version in vm's configuration data (in our case to 18) and after that trying to invoke spec_version = 16 on top of that. But because the version should be same, it's failing. Same error occured when you are trying the same in REST Explorer - "vms". SCRIPT: Import-Module d:\temp\PSNutanixPrismCentral.psm1 Invoke-NutanixPrismCentralLogin -Username "username@xxx.local" -Uri "https://prismcentral.xxxx.local:9440" # Get non default projects $Projects = Get-NutanixPrismCentralProje
Below are new knowledge base articles published on the week of October 6-12, 2019. KB 8046 - Set Up Frame Admin user with Domain Joined Instances KB 8076 - Sysprep fails on Windows 10 due to AppX packages not being installed for all users KB 8098 - Renewal of licenses/Buying new licenses KB 8101 - Licensing Steps to License Capacity Based Starter License KB 8149 - NCC Health Check: check_dvs_esxi_version_compatibilty KB 8151 - Saml authentication using ADFS unable to login KB 8229 - Alert Email Digest gets delayed within 30 minutes in AOS 5.10.5 or later KB 8237 - Kubernetes Dashboard deployment fails due to incompatible version with Kubernetes cluster. KB 8249 - LCM Pre-check : test_node_uuid_validity KB 8282 - Poor thread load balancing within RHEL/CentOS guests constraints guest IO performance KB 8304 - Era Server displays incorrect time after reboot KB 8312 - VMs not getting IP address from IPAM KB 8313 - AHV | Kernel debugging of Windows VM via network (KDNET) KB 83
Prior to AOS version 5.1.2 memory_reserved had not been populated at the time of VM creation. Once the VM was powered on the memory_reserved field was populated and the value remained persistent even when the VM was powered off. The issue was fixed in version 5.1.5 and 5.5 and above. It is important to remember that there is no over-provisioning of memory in AHV. The "total provisioned memory" amounts to all the memory configured on all VMs regardless of power state. The "total reserved memory" is memory configured to all Powered on VMs only.
Once you complete firmware upgrade start prepping for another one. Eternal compatibility matrix checks, arguments with vendors on a version that is supported by both compute and hypervisor, forgetting to include plugins into upgrade and the list just goes on and on. Sounds familiar? There is a way out. Developed as the second generation of one-click upgrade LCM simplifies this problem for Nutanix environments. LCM provides a single process in Prism that identifies and qualifies upgrade paths against tested and validated versions, then uses a nondisruptive one-click process to complete the upgrade. LCM can perform firmware upgrades on the following server platforms: Nutanix NX appliances. Dell XC and XC Core appliances. Lenovo HX and HX Core appliances. When you upgrade firmware, we recommend that you use the latest versions of AOS, Foundation, and LCM. Quick snapshot of LCM workflow: Interested? Start with LCM glossary. Coffee read on LCM: Nutanix Upgrades: Life Cycle Manager
Hi, We have several Hyper-V servers. We intend to implement Nutanix to replace those Hyper-V servers. We have been given Nutanix Collector win32 v2 to run collecting the information of the Hyper-V servers to estimate what Nutanix to buy. However, I don't know how to run it. Has any one run this before ? Is there any guide document ? Thank you very much for your help.
I'm curious to find out how folks have been implementing departmental shared folders in nutanix files. We are currently running SMB files from a NetApp filer which has the ability to setup Qtrees/quotas for subfolders of the top level share. Is this possible in nutanix files as I'm not seeing anything in the documentation around it.
Hello I'm new to Nutanix and setting up a small 3 node cluster with ESXi. Just wanted to know whether there is any automatic migration from Nutanix side in case of resource contention on 1 node. One such example: if there are too many VM hosted on a single node and causing storage contention, is there any option on Nutanix to automatically migrate some VM to other nodes (similar to what VMware DRS does - but this time, for storage) Thanks
Looking to strengthen security of your HCL cluster? Consider keeping only necessary ports open. Following is the list of firewall ports that must be kept open to successfully access the Nutanix cluster. Prism web console: 9440, 80 SSH to both CVM and Hypervisor: 22 Cluster remote support: 80, 8443 vCenter remote console: 443, 902, 903 from both the user host and vCenter vCenter from Prism web console: 443, 80 Citrix MCS: virtual IP, Port 9440 (TCP) Xtract for VMs (Move): ESXi hosts (TCP 443, 902); AHV (TCP and UDP 2049, 111) Following is the list of ports that must be kept open for the 1-Click upgrade. *.compute-*.amazonaws.com:80,443 release-api.nutanix.com:80 ntnx-portal.s3.amazonaws.com and s3*.amazonaws.com Information above is extracted from KB-1478 which also explains what to do when configuring the entire range of IP address for AWS is not acceptable and using FQDN wildcards is not an option supported by the firewall the environment. KB-1202 Lists port number
In addition to data compression and data deduplication — features that are expected nowadays to be present on any storage aware platform Nutanix AOS also offers Erasure Coding. For workloads with cold data present (no write within past 7 days), when enabled, EC encodes a strip of data blocks on different nodes and calculates parity. In the event of a host and/or disk failure, the parity can be leveraged to calculate any missing data blocks (decoding). In the case of DSF, the data block is an extent group and each data block must be on a different node and belong to a different vDisk. Once parity is computed, the data block copies are removed and replaced with the parity information. Workloads Recommended for Erasure Coding Write once, read many (WORM) workloads. Backups. Archives. File servers. Log servers. Email (depending on usage). Workloads Not Ideal for Erasure Coding Anything write- or overwrite-intensive. VDI. Because of data-avoidance technology like intelligent c
Hello, I'm trying to clone from a known UUID (our template) but I keep getting a 400 code for "Bad request" Ex : (Using Postman for this example, but have also tried with POSH and had the same result) POST https://1.1.1.1:9440/api/nutanix/v3/vms/{UUID}/clone Basic Auth - admin/pw Headers - Content-Type:application/json Once I send the API call, this returns : { "api_version": "3.1", "code": 400, "message_list": [ { "message": "Bad request.", "reason": "BAD_REQUEST" } ], "state": "ERROR" } Any advice / help would be appreciated. This has been boggling me as to why it'd throw this error. Thank you!
Occasionally you need to temporarily power off your cluster hardware for maintenance, relocation or any other necessary task. To do this you will need to stop your cluster and then start it back after the required task was done. But you will need to perform the following tasks before and after the cluster stop/start commands: 1- Disable any “Protection Domains” in the cluster and make sure there is no ongoing replication occurring. 2- Make sure no “Fail” message appears when performing the ncc health check on the cluster 3- Power off all the Vms running in the cluster 4- Stop “Files” (previously AFS) if you are using it in the cluster 5- Run "cluster stop" command 6- power off all CVM 7- Put all hypervisors in maintenance mode 8- Power off the hardware After the maintenance and powering on the hardware, you will need to undo the above steps. Put nodes out of maintenance mode and make sure all Cvm are powered on, to run the command “cluster start”; you could then go ahead with st
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.