Have questions about how the Nutanix Platform works? Looking to get started - start here!
Recently active
Let’s say that you want to dive deeper into the performance of your AHV cluster to understand if the resource allocation has been done correctly and to check how many CPUs, Cores per CPU and Threads reside on each host. To see the CPU components, SSH to a CVM in your cluster and run ”hostssh lscpu”: The result above is an output example of one node, for this host there are: Sockets = 2 Cores per socket = 6 (2x6 = 12 in total) Threads per core = 2 (2x12 = 24 in total) CPUs = 24 (threads in total) If you wish to see more information for each of the 24 CPUs on this host you can run "cat /proc/cpuinfo" on a host shell (not through the CVM). To jump from the CVM to it’s host, run “ssh root@192.168.5.1” and run the command above.
Can anyone let me know which steps are being involved when I expand Hyper-V cluster by using Prism? I have a Hyper-V cluster that being mixed by some AHV storage nodes and looks like I cannot use the Prism cluster expansion feature to add more nodes...
Can we have a document on Ncli
Regardless of the type of data you generate on your VMs, the data has to be backed up and safe. how do you make sure of that? a first step is to understand our basic approaches and how do we guarantee data resiliency. The importance of data protection increases as the amount of data generated by your VMs continues to grow at unprecedented rates by expanding your storage pool, adding nodes to your cluster and deploying new Virtual Machines. To ensure that the data is safe, we have different approaches, here is a brief explanation for each: Protection Domain (two types) Protection domain - Asynchronous DR: is a defined group of entities that consists of VMs and Volume groups that are backed up locally on the cluster and can also be replicated on a remote site. Protection domain - Metro Availability: is a pre-specified and an active storage container in the local cluster linked to an inactive container with the same name on a remote site in which synchronous data replication occurs whe
Let’s say that you need to use Phoenix on a node, how do you know which ISO is best for you? the minimal or a bundle of Phoenix & AOS? How do you create the bundle? The short answer for both questions is, it depends. What is Phoenix? Phoenix is an ISO-based installer that you can use to perform installation tasks on bare-metal hardware one node at a time. Tasks that performed by Phoenix: Configuring Hypervisor settings, virtual switches and more (no need for AOS in this case) Installing the Controller VM which runs the AOS. Installing the Hypervisor on a new or replacement node. Repairing the CVM. If you don’t have access to the CVM and you want to check the data drives’ health, you will be able to see the drives from the Phoenix shell. How do you obtain the correct Phoenix? Looking at the scenarios above, we can see that for each case you might need a different approach and ISO, but all scenarios require the minimal Phoenix ISO. You can download the minimal Phoenix ISO from
Below are the top knowledge base articles for the month of January 2020. KB 4116 - Alert - A1187, A1188 - ECCErrorsLast1Day, ECCErrorsLast10Days KB 4141 - Alert - A1046 - PowerSupplyDown KB 7503 - G6, G7 platforms with BIOS 41.002 and higher - DIMM Error handling and replacement policy KB 1540 - What to do when /home partition or /home/nutanix directory is full KB 4541 - Alert - A101055 - MetadataDiskMountedCheck KB 1113 - HDD/SSD Troubleshooting KB 4158 - Alert - A1104 - PhysicalDiskBad KB 4409 - LCM: (LifeCycle Manager) Troubleshooting Guide KB 2090 - AHV | Host and Guest Networking KB 4188 - Alert - A1050, A1008 - IPMIError KB 1507 - Alert IPMI IP address on Controller VM {CVM-IP} was updated to ... without following the Nutanix IP Reconfiguration procedure, can be misleading KB 4519 - NCC Health Check: check_ntp KB 4494 - NCC Health Check: metadata_mounted_check KB 4705 - Alert - ExternalClientAccessCheck KB 2473 - NCC Health Check: cvm_memory_usage_check KB 8514 - NCC Health Check
Below are new knowledge base articles published on the week of January 26-February 1, 2020. KB 8861 - Calm - Can't edit/delete task library when the associated project gets deleted KB 8891 - Lenovo XCC/IMM upgrade via LCM : "Failure in executing cmd:ifconfig usb0 169.254.95.120" KB 8896 - Multiple disks marked offline on node running PH16 firmware Note: You may need to log in to the Support Portal to view some of these articles.
can we replace an existing node with a better hardware, that is with the latest processor?
AOS upgrade appears to go well, but my CE three node cluster didn’t complete the first AHV upgrade. Now CVM is off line. I’m looking a logs but not sure what to look for. /var/log [root@NTNX-04524900-A log]# cat ahv-host-agent.log 2020-01-30 19:02:44,734 host_agent_.py:34 INFO Starting host agent 2020-01-30 19:02:44,734 host_agent_.py:67 INFO Generating /var/lib/ahv-host-agent/schema//api.json 2020-01-30 19:02:44,818 host_agent_.py:92 INFO Connecting to libvirt 2020-01-30 19:02:44,819 task_store.py:354 INFO Started task garbage collector 2020-01-30 19:02:44,821 host_agent_.py:98 INFO Connected to libvirt 2020-01-30 19:02:44,821 manager.py:50 INFO Starting CollectorManager 2020-01-30 19:02:44,825 manager.py:50 INFO Starting pid monitor OvsVSwitchdMonitor 2020-01-30 19:02:44,825 manager.py:110 INFO EventManager thread is listening on 127.0.0.1:2031 2020-01-30 19:02:44,825 process_monitor.py:99 INFO Starting ovs-vswitchd process monitoring ... 2020-01-30 19:02:44,872 server.py:56 INFO S
Dear All Is it mandatory to replace the node in a cluster with the same hardware? Can we replace it with a higher configuration(CPU)
Below are new knowledge base articles published on the week of January 19-25, 2019. KB 8805 - AHV | How to change hypervisor identity KB 8848 - Listing VMs via CLI for importing into Excel KB 8853 - ESXi ixgben technical details and known issues KB 8858 - AHV | Hypervisor 1-Click upgrade troubleshooting scenarios Note: You may need to log in to the Support Portal to view some of the articles.
Dear Sir/ Madam, I am working on a further Nutanix project and I have installed 8 x NX8155 servers. Each server has 6 x 10g TwinX cables and 2 x CAT6 copper connections. I am again trying to find any suitable cable manager due to the amount of physical cabling for each device. Can someone please advise if there are any cable managers that Nutanix is aware of or via a third party as I am struggling to locate any. Thanks in advance. Simon.
Hello all, I just realize that it is available IBM HCI servers with Power9 processor together with Nutanix. As far as I can understand from the documentation it is only for AIX and Linux workloads? My question is: is it posible to run workloads with OS400-AS400 instead of AIX? Thanks Best Regards Javier de Mingo AGROSEGURO
The cluster is up and running and we are getting error “Disk 'root' space usage high on host” Can /home/install/phx_iso be deleted?
I want to exclude some disks from my snapshot, using Rubrik on my Nutanix VM. I use the script from rubrik (which is a Patch) to exclude some disks from my nutanix vm like this: { "excludeDiskIds": [ "diskid1", "diskid2" ] } I get these disks id from the nutanix API (which is a get), but when I snapshot the machine from Rubrik the disks are still included. Am I doing something wrong? Is the "Nutanix Disk ID" equal to the one requested from the Rubrik script? Thank you
Below are new knowledge base articles published on the week of January 12-18, 2019. KB 8801 - How to change between TTY (virtual terminal) on Linux guest VMs when using a console launched from Prism Element KB 8804 - Xi Beam Issue KB 8811 - AHV | ISO image file with uppercase extension "ISO", detected as "DISK" during image creation KB 8814 - AHV | How to create VM templates KB 8832 - AHV | Generic troubleshooting scenarios KB 8835 - AHV | How to add or remove NICs from bridges KB 8838 - AHV | How to upgrade using LCM Dark site bundle KB 8841 - Nutanix Files - UID and GID differences for Multiprotocol shares KB 8847 - How to Change Background of Production Instances Note: You may need to log in to the Support Portal to view some of these articles.
Is there a way to create isolated networks within the nutanix cluster that would allow communication only for the VMs that has a NIC connected to that network? Find attached an example of what I mean if we were talking about ESXi Thanks in advance!
Remote diagnostic service is an on-demand log collection from Insights which leverages Pulse workflow, which is used to diagnose a specific issue which can be related to specific service, unlike pulse which provides a high-level log collection service. The remote diagnostics allows Nutanix support to collect a set of logs for troubleshooting a specific issue and it contains: Services related logs Custom gflags Activity traces for Nutanix services Hypervisor logs and configuration System statistics NCC health check reports Workflow When Nutanix Systems Reliability Engineers needs some diagnostics data to be collected they go through the following workflow: The Remote diagnostic is enabled by default with Pulse and Remote Diagnostics can be disabled later by having the Pulse service still enabled which is required for proactive monitoring of the cluster. Only authenticated and authorized users from support, sales and customer success can use the Nutanix Remote Diagnost
Hi, I am having a Hyper-V cluster managed by a SCVMM with Kerberos enabled. I already did: Join the cluster and hosts to domain Create the MSFC and join to domain Add hosts and Nutanix container share to SCVMM Enable Kerberos and configure Delegation But, from each host, I currently cannot: Access to Nutanix container via SMB path (\\VIP\container). When I type the SMB path into file explorer, it requires me to login. I tried to use the AD account used to enable Kerberos on Prism as well as AD admin account but could not make it Create the VM (I could create the VM by using SCVMM instead). “Failed to create the virtual hard disk” error window appears every time I try to create Is this the normal behavior of the whole system? As I am quite new to Hyper-V, I am getting lost in finding the solution to solve it
We are thinking of adding two compute only nodes to our cluster for Oracle. What are the hardware requirements for running CO nodes? Does the cluster the CO’s are joined to have to be all flash or do you have to “pin” the VM’s running on the CO to All Flash in the HC storage. We currently have 4 HC nodes running a mix of SSD and HDD.
Below are new knowledge base articles published on the week of January 5-11, 2019. KB 8725 - AHV | Cluster expansion or host boot disk replacement may fail on AOS 5.16 KB 8727 - AHV | LCM does not offer new AHV versions after upgrading AOS to 5.16 on cluster with GPU cards KB 8732 - AHV | 1-Click hypervisor upgrade may fail on mixed cluster running AOS 5.16 KB 8790 - ESXi - Supporting 6.0 series on G7 KB 8792 - NCC checks: same_hypervisor_version_check, duplicate_cvm_ip_check, same_timezone_check giving ERR KB 8793 - Firmware update for DX+DL mix cluster KB 8796 - AHV | Windows installation fails with "No signed device drivers were found" error KB 8799 - Syslog setup for Prism fails with port error KB 8806 - AHV | Windows Server OS may crash when hot-adding vCPU KB 8815 - [Karbon] Deployment fails on etcd volume creation Note: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of December 29, 2019-January 4, 2020. KB 8463 - HDD/SSD failure can cause CVM reboot KB 8464 - LCM - Why VMs are detected as non-migratable during update operation ? KB 8778 - AHV | Bitlocker cannot be enabled on Windows Server 2019 in VM running on AHV KB 8779 - Check the Foundation version installed via CLI Note: You may need to log in to the Support Portal to view some of these articles.
Hello all, Hope you’re all doing great. Kindly if you can guide me where to start with Nutanix as I don’t know anything and willing to know everything related .. so I am a VMware guy who is willing to understand the NU platform and I hope I am writing the right post in the right place Thanks in Advance, Cheers.
Below are the top knowledge base articles for the month of December 2019. KB 4141 - Alert - A1046 - PowerSupplyDown KB 4116 - Alert - A1187, A1188 - ECCErrorsLast1Day, ECCErrorsLast10Days KB 7503 - G6, G7 platforms with BIOS 41.002 -DIMM Error handling and replacement policy KB 1540 - What to do when /home partition or /home/nutanix directory is full KB 4541 - Alert - A101055 - MetadataDiskMountedCheck KB 4494 - NCC Health Check: metadata_mounted_check KB 1113 - HDD/SSD Troubleshooting KB 4158 - Alert - A1104 - PhysicalDiskBad KB 4409 - LCM: (LifeCycle Manager) Troubleshooting Guide KB 2090 - AHV | Host and Guest Networking KB 1888 - NCC Health Check: storage_container_mount_check KB 4188 - Alert - A1050, A1008 - IPMIError KB 4519 - NCC Health Check: check_ntp KB 1507 - Alert IPMI IP address on Controller VM was updated to ... without following the Nutanix IP Reconfiguration procedure, can be misleading KB 3357 - NCC Health Check: ipmi_sel_cecc_check KB 8514 - NCC Health Check: fs_inco
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.