Nutanix Community Edition. The Prestige

  • 11 March 2016
  • 34 replies
Nutanix Community Edition. The Prestige
Userlevel 7
Badge +35
This post was authored by Richard Arsenian, Nutanix Global Solution Architect – OEM Alliances | VCDX #126 | NPX #09

Whether you’re watching on television or fortunate enough to see someone like Chris Angel or David Copperfield live on stage, we’re all captivated one way or another by the illusions performed by these artists.

Some of us immediately start dissecting the choreographed act like a detective at a crime scene, in hope that we can solve the mystery or the typical cliché of how the assistants legs became detached from his/her body - Then of course, re-attached once again.
One of my favourite movies “The Prestige” - Michael Caine explains to us that every magic trick consists of 3 parts – known as “the acts”

“The first part is called The pledge; where the magician shows you something ordinary: a deck of cards, a bird, a manwoman. The second act is called The Turn. The Magician takes the ordinary something and makes it do something extraordinary. But you wouldn’t clap yet, because making something disappear isn’t enough. You have to bring it back. That’s why every magic trick has a third act. The hardest part. The part we call The Prestige."

You’re probably wondering what magic or a magician has to do with Nutanix – Well since Nutanix started in 2009, we’ve been performing, what I like to call, REAL Magic through Hyperconvergance and Webscale Technologies – This has translated into making the Datacentre truly invisible.

Something which seemed like only an illusion to many has now been widely adopted in all verticals spanning from the Global 500 of companies to the small business

There are vendors out there that have tried to clone our “acts”, though almost all of them have fallen short of the “Turn” – Let alone have ever made it to “The Prestige”. It’s nothing but an illusion.

When revealing the method behind one of his tricks, Christian Bale advises a youngster to “Never show anyone. They’ll beg you and they’ll flatter you for the secret. But as soon as you give it up, you’ll be nothing to them. The secret impresses no one. The Trick you use it for is everything”

Since Nutanix isn’t creating an illusion, trick or more importantly afraid of becoming “nothing” once we reveal the interworking’s to our technology – We have (and will continue to be) very transparent. The Nutanix Bible ( as well as our rockstar bloggers like Josh Odgers ( and Michael Webster ( are a great example of this, not to mention the ability to install our software on your own hardware at home, lab or up in the cloud.

Welcome to the Nutanix Community Edition (CE)

What is the CE edition?[/h2]Community Edition is a 100% software solution enabling technology enthusiasts to easily evaluate the latest hyperconvergence technology at zero cost. Imagine having the ability to experience and test drive the same Nutanix technology that powers the datacenters of thousands of leading enterprises around the world on your own hardware – Something that was never possible with 3 Tier Architecture.

Community edition can really be consumed in two ways:

This topic has been closed for comments

34 replies

Badge +6
Great article. Quick question about hte disks. Did you install booth disk inside the NUC? or is one of them attached to the NUC by an USB cable?
Badge +3
Great info! I would love to know how the case was customized!
Userlevel 7
Badge +35
Hi  - let me see if I can get some info for you
Badge +1

Yes, the device has internal support for both:

Look under Storage (I can't cut and paste from it)

m.2 up to 8cm long (huge) and a 9mm 2.5"
Badge +6
I see, it is because the SSD is the M2 that you can do both at the same time. Correct? 
Badge +5
Correct: the SSD uses an M.2 interface and the HDD uses a SATA Connector.

Both are present in the NUC. The USB is used to boot the hypervisor
Badge +10
Great article, was waiting to see if it would work on an Intel NUC. Ive been thinking about purchasing one and upping it to 32GB of RAM (around $350 for a pair of 16Gb low voltage sticks), officially it isnt support but it appears to function on some NUC 5th CPU GEN models (models below).

  • Intel NUC5i7RYH
  • Intel NUC5i5RYH
  • Intel NUC5i5MYHE
  • Intel NUC5i5RYK
  • Intel NUC5i3RYH
  • Intel NUC5i3MYHE
  • Intel NUC5i3RYK
3 or 4 Nodes in a cluster each with 16GB of usable RAM you could get a nice functional home lab environment, considering the work loads you could even consider lowering your CVM ram allocation just a little to squeeze more RAM capacity.

Info from:
Badge +5
Yea i've seen those .. Haven't tested them myself.

Though the new 6th Gen NUC's do support 32GB RAM, so might be worth taking a look at those.

re; the 3-4 Nodes in a home lab... Yes this would be perfect! and from my testing, you could slightly lower the CVM requirements too 🙂
Badge +10
great for it to be officially supported now!
Userlevel 7
Badge +35
I just purchased a 6th gen NUC - still waiting to get all the parts, but I'll also provide my details once I get it pulled together. I purchased the NUC6i3SYH (.. Budget reasons).
Badge +7
You can also get a variety of 3rd party cases.

In terms of graphics work, not sure exactly how it was done but for about $35 SkinIt! will do custom skin for the NUC.
Userlevel 1
Badge +6
I am running CE on a NUC6 - the i5 model with 32GB :)

I have a post in the CE forum, hardware thread, on what I had to do to get it going. As the budget allows I'll get (at least) two more to make it a proper cluster.
Userlevel 7
Badge +35
Great to hear, I am still waiting for my RAM to arrive, hoping to also get a second one if the dollars make cents 🙂
Badge +7
Decided to play along at home. Going to buld a small cluster using Intel NUCs.

Think I also have some really old Supermicro 1U servers somewhere - just need to validate they support VTx and swap out one of the HDDs for an SSD.

Stay tuned for more information
Badge +2
I has setup MacVim and I wonder where and how to find the file of"", Thanks.
Badge +5
The file is located on your bootable USB
Badge +2
Yes, I have found it and edit it with vi command. Thank you. But there's not only "Min_Cores" problem, and also as below pic shows.

Badge +7
ricky_ruan file is located at /home/install/phx_iso/phoenix/ on the NutanixCE image you downloaded

There are two ways to edit it:

1) Mount the image on another Linux box then edit it.

2) Log in to the NutanixCE image once it's booted as 'root' instead of as 'install' using the password 'nutanix/4u'
Badge +2
Thanks for your help. But many many erros in installation checks.:manfrustrated:
Badge +5
Can you please describe in detail your setup.. hardware, controllers, disks etc.. ?
,I have a NUC6,too. and I want to install the CE on it. but I failed. It show "No GigE or 10Gige",It mean the system can't load the NIC driver, How do you resovle it. thanks.
Userlevel 7
Badge +35
Hi  - I am still waiting for my RAM, so I haven't installed it yet, but maybe  might be able to share some thoughts.
Badge +1
It is prompting me for a "Next" user/pass? I have a Nutanix account but someone else downloaded the image. Also I was able to log in as root with the credential posted above and did a "halt -p" to power cycle the box as I want to bring it back up . Nothing booting. Like there is no bootable partiion on the disk.
does anyone know how to make this work without using an SSD and using 2 sata drives?
if anyone is interested in how to make this work with a smaller SSD drive and installing it on a machine probably virtual as well as physical(physical worked for me), here is what i did to make it work. i downloaded the iso from the internet, the ce-2015.11.05-stable.img version that is 1.95gb in size. i am sure others would work as well. but this worked for me.

i went into the file.

altered the ram and cpu to be less than what is listed as the defaults. modified the ssd value from 199 to 99. anywhere there is 199, change to 99. i had a 120gb ssd drive and it worked for that.

basically vi and :wq to save your changes. press insert key to overtype the numbers.

I used rufus to format the usb 16gb disk and that is what it uses to boot from when you install the Acropolis to the stick.

i did not do dhcp, but you can if you want. i did static ip address.

the default login to CE is admin admin, then it will prompt you to change the password.

jut log into your ip address as https://ip and your golden.