Question

Upgraded to PC by Accident


Userlevel 1
Badge +9
I picked the wrong upgrade bundle and upgrade a node to Prism Central.

Can I "Upgrade" to the full version?

This topic has been closed for comments

22 replies

Userlevel 7
Badge +25
You mean make a CE PC instance a Commercial PC instance for managing Commercial Elements? If you were able to "upgrade" an AHV instance to a PC load that would be a funny defect in the pre-check.

Belief it was a fork of Commercial so guessing it may make a mess, but not sure if I understand your goals.
Userlevel 1
Badge +9
I had CE, I upgraded it to CE-PC by accident. I don't want CE-PC, I just want CE.
Userlevel 7
Badge +25
PrismCentral is just a VM running on your CE cluster aggregating CE clusters? It should be in addition to Prism Element which is the UI for a node in your CE cluster not replace it?
Userlevel 1
Badge +9
Well it looks like I upgraded PE to to PC.
Userlevel 7
Badge +25
Did you use the same IP address in your PC config as your PE cluster/node IP? Would have expected an IP conflict which may be masked in the OVS domain. Prism is running on each node mediated by Zookeeper as electing the master so you can't "upgrade" element beyond upgrading AOS which would still be element.

What happens when you shut down your PC instance? Does the PE UI magically come back?
Userlevel 1
Badge +9
[root@NTNX-684d656e-A ~]# virsh list
Id Name State
----------------------------------------------------
7 NTNX-684d656e-A-CVM running
8 e335b238-9c49-4ac7-867e-69a8969c7a06 running
9 286f397e-e806-4dfa-a4fc-c98e6b4afa80 running



The two "non cvm" vm's are vm's I had on the box before the upgrade.

When I connect to the cvm I get:

Userlevel 7
Badge +25
Well that's the Self Service UI from what I see (no first party experience with that feature)

I get the same error if I browse to https://ce-cluster:9440/ssp/ on my element instance rather than https://ce-cluster:9440/console/

Were you using the Self-Service feature before you did your upgrade? Wondering if the "default" page is messed up in element?
Userlevel 1
Badge +9
We never used the Self-Service feature before.
Userlevel 1
Badge +9
I also used ce-pc-2018.01.31.tar.gz to upgrade ce.
Userlevel 7
Badge +25
And you still get the /ssp redirect when you browse to /console?
Userlevel 1
Badge +9
If I try to login to /ssp i get:

Userlevel 7
Badge +25
Well SSP would be selling service. What about /console?
Userlevel 1
Badge +9
/console I get:

Userlevel 1
Badge +9
If I click on "N" i get:

Userlevel 7
Badge +25
Weird so element redirects to the self service. That's more than a bit odd. Any chance you can nuke and pave?
Userlevel 1
Badge +9
I would prefer not to nuke/pave. I would like to get element back.
Userlevel 7
Badge +34
Hi @kfr-

Just wanted to check back and see if you were able to make any headway on this or found a solution you can share in the community forums? Let me know 👋
Userlevel 1
Badge +9
So far, no. I havn't paved it yet either. I'm going to guess that I can "upgrade" it back to CE when a new version gets released. I might try that.
Userlevel 7
Badge +34
Hey @kfr- If you haven't nuked/paved it yet I think a new release of CE should be out shortly.
Userlevel 1
Badge +9
Hey @kfr- If you haven't nuked/paved it yet I think a new release of CE should be out shortly.
I paved it.
Userlevel 7
Badge +34
Hi @kfr-

After 'paving it' how did things go? have you done a reinstall?
Userlevel 1
Badge +9
It re-installed fine.