Solved

Not included VM

  • 19 January 2017
  • 6 replies
  • 2 views

Badge +4
Set nutanix 2017.01.10, create cluster of 3 nod, create VM without discs. VM starts to boot over the network. If adding a disk or CD-ROM and press Power on nothing happens - VM not included. What is the reason that you're doing wrong.
,"01/19/17, 11:43:54 AM","5 minutes
Create Virtual Disk","VM : test",100,"Succeeded","01/19/17, 9:19:22 AM","Under 1 second
VmSetPowerState","VM : testNode : NTNX-f51b29f3-A",100,"Succeeded","01/19/17, 8:00:29 AM","Under 1 second
"VmSetPowerState","VM : testNode : NTNX-5edf5e85-A",100,"Failed : Traceback (most recent call last):
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/util/task/base_task.py", line 504, in _resume
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/hypervisor/host.py", line 74, in wrapper
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/vm/set_power_state_task.py", line 206, in _run
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/vm/set_power_state_task.py", line 289, in _power_on
File "/usr/lib64/python2.6/contextlib.py", line 23, in __exit__
self.gen.next()
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/vm/set_power_state_task.py", line 286, in _power_on
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/hypervisor/kvm/libvirt_connection.py", line 123, in wrapper
File "/home/hudsonb/workspace/workspace/asterix-ce-BUILD/builds/build-ce-2017.01.10-stable-release/python-tree/bdist.linux-x86_64/egg/acropolis/hypervisor/kvm/power_mixin.py", line 123, in power_on_vm
File "build/bdist.linux-x86_64/egg/pylibvirt.py", line 407, in createXML
cimpl = self._pool.call("DomainCreateXML", self._cimpl, xml_bytes, flags)
File "build/bdist.linux-x86_64/egg/pylibvirt.py", line 111, in call
raise libvirtError(*err)
libvirtError: operation failed: domain is no longer running
icon

Best answer by Kalabuk 30 January 2017, 14:00

Figured out. On installation the host IP Address and CVM IP Address are on the same subnet. It worked.
View original

This topic has been closed for comments

6 replies

Userlevel 6
Badge +30
Good question, thanks for posting that traceback error. I'll ping engineering internally to see if we've got an eye on this one.
Userlevel 6
Badge +30
Have you done the associated hypervisor update after you installed the 01.10 release? That hypervisor update is posted in the same location you got the 01.10 download.

Either way, it sounds like QEMU might be crashing, can you collect the logs from the AHV host here: /var/log/libvirt/qemu/.log and upload them to a filesharing service of some sort?
Badge +4
Yes, hypervisor AHV version 20161118.100427. Mounted on a platform Supermicro and Intel, boot from the USB flash and sata DOM, tried old and new images, different variants SSD and HDD the result is the same - disk VM machine not included. A year ago I installed nutanix ce-2016.03.13-stable.img - all is ok, today the same problem. Log https://ru.files.fm/u/7cgyzz4m
Badge +4
The BIOS settings can influence. Supermicro SYS-2028TR-HTR (BIOS Version : 2.0b), 2 Intel Xeon E5-2637v3, 8 DDR4-2400 16Gb 2R*4 ECCSSD Samsung SM863 480Gb, HDD Seagate Enterprise 7.2k 2Tb, SMC SATADOM 16Gb, SuperMicro AOC-STG-I2T. Put on bare metal and ESXi - the result is the same - mounted disk VM does not start.
Badge +4
no ideas?
Badge +4
Figured out. On installation the host IP Address and CVM IP Address are on the same subnet. It worked.