Question

Help Needed With Community Edition Download

  • 25 September 2018
  • 28 replies
  • 27 views

Badge +1
I have recently downloaded both the disc image and iso files for the Nutanix community edition but I keep getting errors when I try to set them up on my workstation pro.
It says;
"could not detect which operating system is in this disk image, you will need to specify which operating system will be installed."

help please!

This topic has been closed for comments

28 replies

I am assuming you are talking about VMWare Workstation Pro...

Have you tried looking at this?
http://www.nutanixpedia.com/p/running-nutanix-ce-on-vmware-workstation.html
Userlevel 7
Badge +34
Hi @jessie

Did the reply from @MonkizzleTC help? Let us know and consider clicking the 'best answer' link to help others in the community to find the same info faster. Thanks
Badge +1
Hello @MonkizzleTC and @aluciani
My apologies for the late reply to your comments. I have been away for a while now.

Thank you for showing interest in post and for the solutions you have proffered.

Forgive my ignorance but I am still unable to smoothly complete the set up process.
There are two issues with the set up process;

Firstly, The disk image I thought I had downloaded (downloaded from Disk Image-based Full Install) turned out to be a file, while the Iso file (downloaded from ISO Installer) turned out to be a disk image. I am confused as to which is accurate.

Secondly, I am unable to download the disk descriptor file from the link that Monkizzle sent to me. These are all I see when I clink on the link and I am not skilled enough to make use of these information and would appreciate more help. Thanks in advance.

# Disk DescriptorFile
version=4
encoding="UTF-8"
CID=a63adc2a
parentCID=ffffffff
isNativeSnapshot="no"
createType="vmfs"

# Extent description
RW 14540800 VMFS "ce-flat.vmdk"

# The Disk Data Base
#DDB

ddb.adapterType = "lsilogic"
ddb.geometry.cylinders = "905"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
ddb.longContentID = "2e046b033cecaa929776efb0a63adc2a"
ddb.uuid = "60 00 C2 9b 69 2f c9 76-74 c4 07 9e 10 87 3b f9"
ddb.virtualHWVersion = "10"
Badge +1

This is a snap shot the issue I mentioned in point 1.
Userlevel 1
Badge +3

Firstly, The disk image I thought I had downloaded (downloaded from Disk Image-based Full Install) turned out to be a file, while the Iso file (downloaded from ISO Installer) turned out to be a disk image. I am confused as to which is accurate.

Well, this isn't even the naming issue, it's just whatever is named "disk image" for server administrators differs from files that are named "disk image" by workstation users.

In fact, these both are disk images, one is an image of a CD-ROM (DVD-ROM and higher) disk, the other is an image of a hard disk. In order to make your image of a hard disk into a hard disk, you need to do some block copy operation, which isn't fully supported by Windows because Windows tends to hide its internal stuff from users, and block access is very internal by its nature. Thankfully, there is a way to directly interpret raw disk copy files.

You have actually displayed the file contents of the "disk descriptor file" instead of having it downloaded, so, in order to download the file, you need to right-click that link and choose "Save link as...", then save it as a text file named "ce.vmdk" instead of any *.txt type Windows-based browsers try to feed you. Then you rename the downloaded *.img file into "ce-flat.vmdk", ignore the extension mismatch stuff if asked, BUT first make Windows Explorer show those extensions, or else you'll have a different name on the file and the next process will fail.

Then, these two files together will represent a valid disk for VMware Workstation Pro to run a system installed on it.
Badge +1
Hello and thanks for your support so far.

I have followed the Nutanix community guide to downloading the Nutanix Ce disk image and disk descriptor file and renamed the files but still get an error message each time I select the disk on my VMware workstation.

Please what am I doing wrong?

Badge +1
This a shot of the error message I keep getting.

Help Please!!!

Userlevel 5
Badge +9
Hi,
is it possible that you have any naming mismatches (e.g. double check the filename in the updated vmdk file vs. the actual flat file)? In the previous post I noticed you still have an .vmdk.txt ending, I'd try to avoid that as it suggests it is a text file... why not just "ce.vmdk"?
Badge +1
Hello Andrew_ct

I have checked for possible mismatches n the file names, converted the files from .txt to ce.vmdk but still get the same error message, " the file specified is not a virtual disk".

I am definitely doing something wrong here but don't know what it is.
Please help!!



Badge +1



Hello Jessie,

you have some Symbols in your Path to File.
Its right that you use "¥" instead of "\"?
Badge +1
Hello everyone!

Thanks to your support, I have been able to scale through this stage of the installation process.
I changed the PC to a Dell Precision T1650 workstation and noticed that I wasn't properly extracting the disk image files after downloading them so I downloaded a file extracting tool called 7-zip, with which I extracted the image file.

However, I am experiencing a little problem with my new PC`s CPU because I am unable to enable VT-x from BIOS. I looked it up on the internet but couldn't find a helpful solution.
The image below contains the error message I keep getting when I attempt ton carryout the installation.

Anyone with any idea as to how to solve this problem, please help.

Badge +1
Hy Jessie,

whats your CPU? and your Bios Version?
Badge +1
Hello Vstefan,

The system information is as follows:

Processor = Intel (R) Corel (TM) i7-3770 CPU @ 3.40GHz
BIOS version = Dell Inc. A28.
Badge +1
Hello Jessie,

Try this:

  1. Look for an option labeled by 'Virtualization Technology' or 'Intel® Virtualization Technology' under 'CPU Configurations', 'System Configurations', 'Advanced' or 'Security' tab and check if the option is enabled or disabled.
  2. If the option is disabled, enable the same.
  3. Save the BIOS settings and Boot by pressing 'F10' key (The key may vary depending on your System Model).

im sure this will help you to:
https://helpdeskgeek.com/how-to/enable-virtualization-in-the-bios/

the VTx is named "Intel Virtualization Technology"

if not, give me an hint.

Thanks,
Stefan
Badge +1
Hello Stefan,

thanks for your support so far!

I have been going through the BIOS myself and have noticed that under Virtualization support, Virtualization is actually enabled. Virtualization for direct I/O is also enabled but the problem still persists.

Also, after setting up the machine, when I power it up, I get a message that say "failed to insert module autofs4 but the machine comes up regardless.

I will google it to find out what it means.
Badge +1
This will help you:

https://geek2pro.wordpress.com/2017/12/31/autofs4-nutanix-ce-nutanix-community-edition/

im sure you have 1) to slow SSD or 2) an combination of SSD/HDD.

Please flag the helping answer 😃
Badge +1
Hello vStefan,

Thanks for your contentious support.
I didn't have to resort to the last help link you sent to me. I had plan on doing so but after redownloading the disk image file and file descriptor I was able to proceed with the installation until the stage in the photo below which I believe to be the last stage.
There's been an error in the download process and seen in this photo and I have been asked to contact the Nutanix community for help with it.
Please how do I resolve this problem?

I also noticed that the CVM IP is automatically provided but I could not see that information during the installation processes.
Any help also with that will be appreciated.

Thanks.

Badge +1
Please provide output from /home/installer/firstboot.out

Do you follow the information provided by @MonkizzleTC ?

http://www.nutanixpedia.com/p/running-nutanix-ce-on-vmware-workstation.html

Do you follow the steps in:

5) Assign Static IPs for the Host (AHV) & CVM.


You must set Static IP for AHV and CVM.
Badge +1
Hello vStefan

These are the contents of the /home/install/firstboot.out file.

Badge +1
Hello Jessie,

it looks like you haven't allocated enough RAM.
please provide your VM Settings.

how much vCPU and vRAM do you setup in your Nutanix5 VM?
Badge +1
Hello vStefan

The Vm settings are as shown in the pictures below.

Badge +1
Okay this seems be good.
how much memory does your system have?

Du you habe less or equal 16GB?
it seems that your system has only 16GB RAM and your operating system and other programs use about 3GB of it.
Badge +1
Hello vStefan,

If am not wrong, the download requirements are 4 processors and 16GB RAM.
I think my PC meets the requirements but I don't know what the problem is.
Could it be that VMware workstation is not compatible with my OS (wondows 10 pro)?
Badge +1
Hello Jessioe,

Yes, you're right, but you need 16GB RAM for the VM. If your whole PC has only 16GB RAM, there's not enough RAM for the VM!

How much RAM does your DELL PC have?
Userlevel 5
Badge +9
Hi,
as @vstefan mentioned, if there is not enough memory on your host and the OS starts to swap to disk during the install/startup of the Nutanix CVM, your boot will likely fail so make sure there is enough memory available (I'd say 4B more than for the VM). I bumped in a similar case where theoretically things should work, but in reality I had to add 4GB to the host. If that is not an option, you could change the cluster minimum requirements, I think I managed to boot the cluster on 14GB, but that is not recommended...