CE.future Early Access: Asterix EA3 Download


Userlevel 7
Badge +30
  • Nutanix Employee
  • 555 replies
Nutanix is pleased to release the following Tech Preview for "the next big thing", referred to commonly as Asterix, and will be known in Commercial as AOS 5.0

Asterix/AOS 5.0 includes over ~60 Major new features, ~200 sub-features, and over ~2,900 misc commits, bug fixes and minor improvements. Not all of these apply to CE, as we've got new stuff for our ESX, Hyper-V, and now Xen Server customers (yep, we support Xen Server now in Commercial).

Some of these changes are right in your face, and some in the background making the sausage faster, better, and tastier.

Either way, there is still a MASSIVE amount of goodness for the CE community, so let's get after it.

RULES AND NOTES
1 - Upgrades from EA to GA version will not work (and if they do, yay us, but dont count on it)
2 - Your tolerance for "this worked before, what gives? type issues is very high
3 - Your tolerance for "why the heck is this bug here?" type issues is very, very high
4 - Fight club rules apply, this is still a private forum
5 - This is an Early Access release, so as such, if you are doing anything you really really care about on your CE cluster, best to just wait for GA.

REPORTING ISSUES
Please review THIS link before reporting issues, it will help us address things in a tight loop: http://next.nutanix.com/t5/Discussion-Forum/READ-ME-Need-Help-Reporting-Issues-for-CE/m-p/9613#U9613

DOWNLOAD LINKS
Bare Metal Installer: http://download.nutanix.com/releases/asterix-ea/10062016/ce-2016.10.05-stable.img.gz
Upgrade Binary from September Release: http://download.nutanix.com/releases/asterix-ea/10062016/nutanix_installer_package.tar.gz
Metadata JSON for Upgrade is attached to this post

This topic has been closed for comments

50 replies

Userlevel 1
Badge +10
Figured I'd be adventurous and do an upgrade vs. clean install. Two things:

Hypervisor version is still 2015 - is that correct? I thought I had read at some point that Asterix would include an updated version of the hypervisor.

NCC version shows as "unknown". I know I'm currently at 2.3.0 and tried running an "upgrade" which succeeded, but the version still shows as unknown in the Upgrade Software > NCC tab.
Userlevel 7
Badge +30
RE Hypervisor - Yes, its still the same. Once we DO get it aligned, it will be way way way easier to keep up to date.

RE NCC - That build has a newer than NCC 2.3 build going on, so it will act a little funky if you do that. Best not to touch it for now.
Userlevel 1
Badge +10
Another error in the upgrade software section:

Upgrade Software > File Server

release-api.nutanix.com could not be reached. Please check Name Server and Proxy settings.
Userlevel 7
Badge +30
Do you have a file server deployed from the previous deployment?
Userlevel 1
Badge +10
Negative. Was playing around with it a little bit last night but didn't have time to go through getting DHCP delegated to the cluster.
Userlevel 7
Badge +30
I'd classify this file server upgrade thing under "move along, disregard" if you dont already have a file server deployed.
Userlevel 3
Badge +15
after upgrade there seems to be a bug in the VM pane of prism - VMs are running but do not show up in prism: Exception while retrieving entities

Userlevel 1
Badge +8
File Server Error: release-api.nutanix.com could not be reached. Please check Name Server and Proxy settings.

Is it possible to have a direct download link?
Userlevel 7
Badge +30
- Do you see anything when you go into the table view? Do you see this exception anywhere else?
Userlevel 7
Badge +30
- Do you already have a file server deployed from a previous installation? or are you trying to deploy a new one?
Userlevel 3
Badge +15
same issue in table view, no issue in other menus

Userlevel 7
Badge +30
Thanks! Under the "Show me why"  - what comes up?

Also, if you SSH to the CVM, under ~/data/logs, do you see and ERROR or FATAL logs?
Userlevel 3
Badge +15
Show me why: Exception while retrieving entities. bunch of Logs there, which one is of interest?
Userlevel 7
Badge +30
a bunch of error and fatal logs? or just a bunch of logs in general.

The most interesting ones would be acropolis.* and any *.FATAL or *.ERROR logs
Userlevel 3
Badge +15
rebooting all CVMs solved the problem
Userlevel 1
Badge +8
New Deployment.
Userlevel 7
Badge +30
We're not releasing AFS for EA3 right now. Will do it for RC1, tenative ~next week.
Userlevel 7
Badge +30
- well, ok then 🙂 Thanks for the info either way, we'll keep an eye out. I dug around in our bug database, and that isn't known, so if anyone else runs into it, let us know.
Userlevel 3
Badge +20
Hi Jon,Is this version of CE Asterix is compatible with nvme drives.Thanksmswasif
Userlevel 7
Badge +30
Not yet
Userlevel 3
Badge +15
Here is another small issue in the EA3:

SMTP Configuration Check is enabled and can not be disabled:

Userlevel 7
Badge +30
- Thanks! We had an internal user hit that, I'm thinking bug, but I'll follow up with engineering.

Also saw your blog on EA, thanks!

Jon
Userlevel 7
Badge +26
I know Raghu pulled Tarak into a convo on the same error including some of the actual alert functionality since the corkscrew test didn't seem to respect proxy settings.
Userlevel 7
Badge +30
- 1 point for finding a bug! 🙂 I've filed internal ticket ENG-68804 for this.
Userlevel 7
Badge +30
So, my internal notes were that I think we have two problems 

First - This is an ugly error, but thats not the point
Second - the point is I dont think the alert is working right.

I already had a ticket in the previous version to address this alert, this is just hitting some new error logic in asterix making it look worse than it is (at least thats my hypothesis)