Solved

Can not access V3 REST API explorer - Server error


On AOS 5.1.x v2 API explorer can be accessed, however when trying to access v3 API (by changing v2 to v3 in URL) getting Server error.

What can be the cause of such behavior and which service should be running for v3 API to work?

Thanks!
icon

Best answer by ivanm 16 April 2018, 08:57

Version is 5.1.3 and this was more of a general question, mainly concerned with if any other service other than Prism is needed for APIs
Thank you all, issue resolved, was happening due to timeouts

View original

5 replies

Well, someone might run into the same issue... Too many snapshots causing timeout could be the issue...
Userlevel 7
Badge +35
Hi @ivanm - you still facing this issue?
Userlevel 7
Badge +30
Depending on which release you're on, you'll see those API's in Tech Preview, or not available at all.

v3 API's are GA'ing in the next release, which is coming out shortly (like very very shortly)
Userlevel 1
Badge +6
@ivanm - Could you please indicate the complete AOS version you are running? As @Jon said, you'll either get the tech preview version of the v3 APIs, or no v3 APIs at all depending on the version you're running.

Above you mentioned 5.1.x but if you could provide the full version we may be able to indicate whether or not that version will allow access to the v3 APIs. For example, 5.1.5 (latest 5.1.x version as I write this) supports tech preview of the v3 APIs, although it's entirely possible that earlier versions of 5.1 didn't.
Version is 5.1.3 and this was more of a general question, mainly concerned with if any other service other than Prism is needed for APIs
Thank you all, issue resolved, was happening due to timeouts

Reply