Server Virtualization

Welcome to the Nutanix NEXT community. To get started please read our short welcome post. Thanks!

cancel
Showing results for 
Search instead for 
Did you mean: 

ESXi 6.5u1 Upgrade on AOS 5.1.1.3

Wayfarer

ESXi 6.5u1 Upgrade on AOS 5.1.1.3

I have recently upgraded my vCenter from 6.0 -> 6.5u1, and I'm not looking to upgrade my ESXi 6.0u3 installs to 6.5u1.  My first attempt was to use one-click hypervisor upgrade, and I was able to uploading the ISO and MD5 checksum, but the pre-upgrade check errors out pretty quickly with a fairly generic error message saying "unable to determine version of bundle."  Did a few re-download and re-upload attempts to verify my file integrity but the error persisted.  I then tried to do the upgrade old-school style using VUM which is conveniently baked into my VCSA as of 6.5, and I got another generic error message inside of update manager, "The upgrade contains the following set of conflicting VIBs:" with nothing but blank space following the colon.  Typically I would have expected to see an individual VIB called out in list form, but there is just nothing there.  I am fully patched to current using Nutanix LCM, so I suspect it is probably one of the LSI HBA updates that LCM has slipped in - has anybody else run across a similar problem?  Did some searching around the VMware community forums and I haven't seen any "blank" incompatible VIB errors so I have a gut feeling that it is a symptom/something related to specific Nutanix LCM updates that we have performed. 

1 REPLY
Explorer

Re: ESXi 6.5u1 Upgrade on AOS 5.1.1.3

I ran into a couple of VIB incompatibilities when I ran VMware Update Manager to upgrade to 6.5u1.  I have a Windows based vCenter 6.5server, but on my Update Manager it told me the VIBs that had problems.

When I attached the baseline with the 6.5u1 ISO and ran a Scan, Update Manager says the Compliance is Incompatable and under Status details I get something similar to this:


The upgrade contains the following set of conflicting VIBs:

Emulex_bootbank_scsi-lpfc820_8.2.4.141.55-1OEM.500.0.0.472560

Emulex_bootbank_scsi-lpfc820_8.2.4.141.55-1OEM.500.0.0.472560

Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.472560

Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.472560

 

(Note: This is from an old HP server, just ran a scan for an example)

To solve my problem I hit google and VMWare, found updated drivers on VMWares site, uploaded them into Update Manager Patch Repository and applied them from there using the Remediate button.  From here I was able to run the ESX 6.5u1 Host Upgrade from Update Manager.

If you cannot get the conflicting VIBs out of Update Manager, I would suggest mounting the 6.5u1 ISO in the Nutanix node’s IPMI interface, and try to run the upgrade.  It will fail, but it should spit out a reason at least and the names of the VIBs stopping it from succeeding.